No vertical scroll bar in screen "Blocks"

in the screen that is for arranging the blocks of a project, there is no vertical scroll bar. To scroll thru the screen I have to use the scroll wheel of the mouse. The horizontal scroll bar is there. It is special to this project. Other projects have the vertical scroll bar.

I already tried “Save as …”. But the copy has still the same problem.

Exporting the project to my computer, deleting the original from App Inventor and reimporting it solved the problem. But that is time consuming.

That is very strange Ulrich. I’m sure MIT would like to fix the issue - how can we reproduce it? Something special with your blocks Layout - different to your other Projects?

Hi Christopher,

sorry, I have no idea how the problem arises and how to reproduce it. The only thing I can say is that the project was relatively big, that is, it consisted of many blocks. The problem has appeared for the second or third time.

I first tried to start another project. The scrollbar was then there. Then when I went back to the original project, it was gone again. Even restarting the browser did not help. The change of the browser FireFox to Chrome didn’t change anything.

I use FireFox 73.0.1 (64-bit) and Chrome 80.0.3987.132 (64-bit).

I suspect the problem lies in an internally stored project property that is not exported when a project is exported.

It’s no longer a big problem for me. I have found a solution. But may be you can identify casually and solve it.

Does use of the block editor zoom (+/-) controls affect the problem?

No, it has no effect.

Your version of Chrome works fine here Ulrich. How many Blocks do you have in your Project?

If a Project is very large, the scroll bar in the Blocks screen becomes difficult to use. Is this the issue?

Here is what happens on a Project with 1600+ blocks

The ScrollBar becomes a small gray dot. I can scroll using the dot moving it up or down using the mouse.

What does an image of the right side of your Browser window look like? Something similar or perhaps you cannot find the ‘dot’ ?

A screenshot of what your browser looks like when this happens and a copy of the project (PM if you need to) would be helpful. The horizontal and vertical scroll bars are in the same group, so there shouldn’t be any reason one would be visible and the other not (except possibly as @SteveJG described).


Maybe (if there is a big project with lots ob blocks arranged in vertical fashion), the vertical scroll bar gets so small that seems to be just a dot, and some times its grey transparent color over the blocks is hard to find.

By the way.
Why the vertical scroll speed (when using the mouse wheel) is so different in designer and blocks screens?
In designer screen, the scroll speed is normal.
But in blocks screen it is so slow, that is unusable. And you are forced to either search for the scroll bar, or point to an empty space between blocks and scroll manually (which is risky, if you drag some block out of their parents).

Would it be possible to set the mouse wheel scroll sped in blocks screen, the same as in designer screen?

In fact, is not the scroll speed in the blocks screen (which is also normal), but the scroll speed inside the blocks canvas, that is so extremely slow.

Which browser and operating system do you use? I find the scrolling speed decent on macOS using Chrome. There may be variations we need to account for by adjusting the gain in the mouse wheel handler.

If find the blocks editor VERY slow with Firefox, even after tweaking Firefox settings

76.0.1 (64-bit) Mozilla Firefox for Ubuntu Canonical 1.0

Browser is Firefox 76.0.1 (64-bit)
OS is Windows 10 Home. version 1903

It had never happened to me before.
But today, when I finished typing a comment, I realized that the vertical scroll bar have dissapeared, as you mentioned.
I was using my dougter’s laptop, with no mouse (nor mouse wheel) available.
Some times, instead of dragging the bar, I click above or below it, to move one sreen height at a time. But it does’nt work either.
I also tried resetting the display to the center of the workspace and fixed zoom, but I couldn’t get the vertical scroll bar back to be shown .
I had to close the window in Firefox, open a new one, browse to AppInventor, log in, open the project, and the bar was there againg.

It happens to me all the time. Vertical scroll bar disappears.
I will try to catch an action that leads to this.
Windows7 64, Firefox 77.0.1(32)

This is related to the usage of 'backpack'. Happens sometimes after backpack was used, not always
Backpack is very buggy itself. It has it's own vertical scrollbar, but does not have horizontal scrollbar at all. Like, if some small blocks are placed there plus a few really 'wide' ones, backpack shows the widest block right end and the shorter blocks are located out of the view in the left part of screen and horizontal scroll bar is missing making it impossible to reach for smaller blocks. this is how it looks:

The issue with the backpack not supporting horizontal scrolling is known. We have an open issue to add horizontal scrolling support. Right now though Blockly only supports having flyouts that scroll in one direction. We hide the scrollbars when the flyouts are open because otherwise you end up with two vertical scroll bars, which people found confusing. The workspace scrollbars should be restored when the flyout is closed, but the behavior of missing scrollbars suggests that this may not always happen.

BTW, I do see 2 vertical scrollbars in Backpack, one for backpack and one for working area sometimes, I am fine with that.
There is never too many scrollbars :slight_smile:
Also I was a bit surprised that even though I place into backpack blocks in compressed shape, they all expand inside backpack. Should they stay compressed, that would eliminate the issue with 'flyouts', at least as a workaround.

I too am finding the mouse (vertical) scroll wheel painfully slow, but only on the blocks; not in the designer window.

Take an .aia export backup of your project, then do a right click Clean up Blocks to line up your blocks in a scroll-friendly format.

1 Like

If using Firefox, try this fix found over on Kodular community ( I have not tried it)