Newbie here...need a little help invoke: no method named `Column' in class

I keep getting this message " invoke: no method named `Column’ in class"
I have tried eliminating all blocks thinking the problem was there but to no avail.
Any help is greatly appreciated.

What were you doing when you got the error message Doug? Using Companion, the emulator and… or something else ?

You eliminated all Blocks. OK, then this appears to be an issue with a component. Are you using Companion 2.58; if not, load it. Are you using an extension? If so remove the extension and try again.

If none of this ‘fixes’ the issue; tell us more about it.


Hi Steve,
Thanks for the reply.
I had made numerous changes on the designer screen since my last connection over AI companion. Then when i tried to connect to see how things were looking, the message appeared.
I have removed all blocks, and tried saving the designer portion under a new name.
Still no fix.
Then I deleted everything in the designer…and still same message.
I started a new app just to make sure there wasnt some other issue and that works ok.
I really dont want to recreate the whole designer screen but the fact that ive deleted everything in it and the problem still exist is weird.
Seems like some top level thing…maybe?

OK. Are you using Companion 2.58 or not?

You " made numerous changes on the designer screen since my last connection over AI companion". Did you create a series of aia files of the Project as you progressed? If you did make the backup files or Save project as and saved previous versions you could use the aia or other versions if you get tired and mess up. If you have a back up, you could back out to a usable version if needed.

What happens if you load a back up file of your penultimate aia?

Yes on the 2.58.
Unfortunately, no saving different files along the way.

What I can’t understand is that if I completely delete everything in the designer,that it still does not work.

Could you export the bad project to an .aia file and post that here for analysis?

Here it is.MicroSplit.aia (202.2 KB)

Loaded it up, deleted everything, and it still generated the error message on refresh when connected to companion (this on a linux system with genymotion emulator). Odd.

MicroSplit_empty.aia (1.1 KB)


I have the same problem and i fix it.

1.export the bad project
2 create a copy
3. rename your bad project to a *.zip and open the zip, open src/appinventor… to the end. you have 2 files, if you have one screen (Screen1.scm and Screen1.bky) extract Screen1.scm and open it with notepad++
4. there is a line code in the beginning like that :
5. remove “Column”:“3” and “Row”:“0” with ,
6 save the file, replace it on your *.zip
7 rename your *.zip to a *.aia
8 import your project.
that’s all

1 Like

Only Column:0 in the original aia :frowning:

you can make ti with the copy if you want

Just tested by removing Column:0 and Row:0 from the scm file, and it seems to have solved it. Well done @Svetlana_GREGOIRE


MicroSplit_copy.aia (202.2 KB)

your working file

So the question is, how did Column and Row get into Screen1 attributes?

Must have been put there by some component. Other question is, if that component was removed, why didn’t it take the column and row with it !! ? :wink:

You guys rock.

Thank you very much!!!

hello i have the same problem i will be happy if you helpfirebasedemo.aia (41.1 KB)

Did you try the workaround from @Svetlana_GREGOIRE

hi i tried to do but i couldn’t I would be glad if you help