Need AI2U 64 bit help with emulator

I am running AI2U 64 bit on a windows machine using google chrome. I am going thru a series of video tutorials that I found on YouTube. Found here,

The authour is using the online MIT App Inventor site. But since I do not have 24/7 access to the internet I am using AI2U which allows me to run app inventor offline. I have gotten up to lesson 3 in that tutorial and everything seems to work well EXCEPT connecting to the emulator. I can get the emulator to run offline but I cannot seem to get the app that I am working on in the design view to RUN in the emulator. I just get the emulator welcome screen that says its emulator 2.43 but I am running app inventor 2.45. When I did go online and tried to update emulator I get a dialog box that says something like. “The AIstarter helper does not appear to be running. Need Help” With and OK button . If I press the OK button the dialog goes away and comes right but. BUT I HAVE run the AI2starter I can see its icon in the taskbar and the dialog that the icon executes in front of my desktop with the “Press CTRL-C to quit” in it. I am truly confused any help would be appreciated.
Thanks

@Shaba1 Sorry you are having issues. The BEST place to get advice about using an emulator with AI2U is to ask questions in the AI2U forum . Someone here might have a solution (we are AI2 users) but you might have better luck if you ask in the AI2U forum https://groups.google.com/forum/#!forum/ai2u . This group has no connection or relation with the third party AI2U stand alone block compiler.

Regards,
Steve

I tried that forum. But it has shut down and redirects you here.

It appears Krupong may have abandoned the AI2U Forum and support. I can’t help with that; sorry.

Users of AI2U have problems when they try to run their aia files created on the MIT server. You will have to have an updated Companion, currently 2.57c.

Users cannot usually mix and match code from a stand alone Block version of AI with App Inventor 2. That might be why you are having issues.

At the moment, what is the issue? Loading the most recent version of aiStarter to use the emulator Instructions for Windows online or getting your lesson to run on AI2U?

Possible problems might be a slow Internet connection. ’ When I did go online and tried to update emulator I get a dialog box that says something like. “The AIstarter helper does not appear to be running.’ Did you follow the advice http://appinventor.mit.edu/explore/ai2/setup-emulator ?

Instead of using the video Projects, try these resources to help you learn to use the AI2 tools A very good way to learn App Inventor is to read the free Inventor’s Manual here in the AI2 free online eBook http://www.appinventor.org/book2 … the links are at the bottom of the Web page. The book ‘teaches’ users how to program with AI2 blocks.

There is a free programming course here http://www.appinventor.org/content/CourseInABox/Intro and the aia files for the projects in the book are here: http://www.appinventor.org/bookFiles

How to do a lot of basic things with App Inventor are described here: http://www.appinventor.org/content/howDoYou/eventHandling .

Also look here http://kio4.com/appinventor/index.htm and here http://www.imagnity.com/tutorial-index/ for more tutorials.

Regards,
Steve

Thanks for your help. As I said I do not have 24/7 internet access. Which is why I downloaded AIU2. So far it works well, except for the emulator not displaying what is in the Design window. I will continue to use it as well as the MIT Cloud based site.

My next action will be to try to open the two emulator ports on Windows firewall. I will let you know my progress.