My emulator is not working

when i was trying to run the emulator , it indicate

i have tried reinstall it but same thing happens, what can i do

i have checked the directory and it is correct as well

You might have to update it instead of reinstalling the same version.

Cuz, the first pic shows some problems with the version.

I'm having the same problem today 5/17; it was working yesterday and all year. Uninstalled/Reinstalled the emulator tools. Installed on Windows using the MIT_App_Inventor_Tools_2.3.0_win_setup.exe. Is there a more recent version to download? Also when running getversion.bat, it says the version is 2.2 even after using the 2.3.0 setup.

For lack of an idea on this particular problem, here are fallbacks to try ...

MIT is currently having server issues. My emulator (aiStarter) does not work either Miki.

Be patient and MIT should fix the issue soon.

Makes sense it's a server issue. I tested with a class after and the entire class couldn't use the emulator. If anyone notices that it's working again, feel free to mention it here.

1 Like

Same issue! Tried with 2 different classes, all using Mac's and none of them were able to test their apps. No emulator, no USB connection, no AI Companion. :frowning:

The server issue we had this morning was fixed around 10:30AM US Eastern Time. If you are still having problems, it is something else. Can you give more details? What happens when you attempt to use MIT App Inventor?

1 Like

Same messages published above (screenshots) appear on every single computer: Unable to retrieve the version of aiStarter installed on your computer. Connection will proceed, but errors may occur.
Using Mac's, tried connecting to iPhone, Emulator and Android tablets via USB.... nothing worked.

@Ana_Luisa_Martinez Try reloading App Inventor now and then connect the companion.

I am now at home, not at school, but I'm having exactly the same issue.

Which browser/device combination are you using?

MacBook Air, Chrome and Emulator
FYI... I tried it with a more recent MacOS at school and same thing

I would be interested in knowing if you have the same problem with Safari or Firefox on the computer. Would you mind testing a connection in Safari?

Not at all... give me a minute

Emulator DOES WORK with Safari and Firefox!

On my Win10 Chrome does not start the emulator but Firefox does. :astonished:

Yes, I am fairly confident that I understand what the issue is. Google is making a particularly problematic change and this is currently interfering with the proper operation of the emulator, the iOS companion, and Android legacy mode.

My classes depend entirely on this site! Do you think it is possible for you (or somebody else) to fix it before tomorrow?

I expect we should be able to fix it tonight.

1 Like