MIT App Inventor Setup is NOT responding

Whenever I click on MIT App Inventor Setup application, a popup appears to allow the app to make changes to the device and I select 'Yes' after that nothing happens. I keep waiting for minutes but nothing happens. I also tried running the app as administrator but the same problem persists. Kindly guide me on how can I setup my MIT App Inventor on Windows.

My Device Info :-
Windows 10 Home
Ryzen 3 Processor

And, I use CHROME for using the app inventor.

I don't think I've heard of this (non-)behavior before. A couple things to check might be whether antivirus programs are interfering with the installer. If you're still having issues even after that, you should take a screenshot of the installer state and attach it to your post.

I even tried it after turning of my antivirus program but same issue is persisting. When I tried to open the program many times (as it is not opening), the setup file automatically disappears from my system and I have to reinstall it. Please suggest any solution as I didn't understood that what you meant by taking a screenshot of the 'installer state'.

Update : When I run the setup application as administrator, the setup window pops up just for a second and immediately disappears.

Here's a video showing my issue :-

You could place the inventor-Tools in your C drive. On most PCs that is the drive it is usually downloaded to. The installer installs to the C drive . It might be having issues installing the emulator there from your D drive. With the installer in your C drive; try again installing as Administrator.

The emulator must be installed in this directory to work with App Inventor

What happens if you try that?

Same thing is happening as shown in the video demonstration. I know that the 'emulator' must be installed in the 'Program Files (x86)' directory.. but we can run the setup file from anywhere.. Still I tried your suggested method, but same issue is there.

Edit : I think you misunderstood my problem. I have problem in installing the emulator or opening the exe file. That's why I have used the word 'setup' file in my query. Although, I tried putting the setup file in Drive (C:) but still there's same problem.

Installers can be used from anywhere, I generally use the downloads section to do that.

We occasionally get posts from people who install aistarter then sit watching the black CMD window waiting for the AI2 GUI to pop up.
We then have to ask them to go to and start a Project, then use the Connect menu from their Project.

are you one of them?

Why not just tap "Open"

@Mayank_Kumar Yes, at first, I tried it from downloads section only. But when it was not running from there, then I moved it on D and C drive.

@ABG Sir, I attached a video in my upper replies, you can clearly see that what's the problem. You are misunderstanding my problem. I have problem in setting up the "ai2starter".

Oakchris1955, I have tried that too, why would I straight away try to run as 'administrator'.

I have run out of ideas as to why you can't install aistarter on your PC.

However, I have a workaround that would give you an emulator and Companion on your PC without aistarter.exe ...

Get and install MemuPlay (see FAQ Section: Companion and Emulator)

Download the Companion .apk file from MIT or Google Play, and drag it onto the MemuPlay desktop to install it .

Move the MemuPlay window to the side, to not block the center of the AI2 web page

From your Project, Click Connect->AICompanion , then highlight and copy (right click) the 6 letter code

Start the Companion in MemuPlay, and paste (Ctrl-V) the code into its input box, then click the yellow Connect With Code button. (I sometimes have to do this twice for large apps or when the rendesvous server is busy)

As you can see from this Windows task manager shot, no MIT software is running on my PC during the emulation.