MIT App Inventor for iOS Version 2.64

Hello everyone,

Apple has approved the release of MIT App Inventor for iOS version 2.64. This release is primarily a bugfix release that addresses the following items:

  • Fix an issue where Player would not produce audio when phones were in silent mode
  • Fix an issue where Map features would not show title and description information
  • Fix an issue where setting the Canvas background to None would show a white background instead
  • Fix an issue where floating point values without a leading zero were parsed as symbols instead of numbers
  • Fix an issue where ImageSprites moved in a delayed fashion
  • Fix an issue where the Slider component did not respect the minimum value
  • Add the ability to use localhost URLs in the WebViewer
  • Implement Dictionary support for iOS
  • Make the screen stay on while editing your project
  • Fix an issue where a misspelling caused certain list blocks to not work correctly
  • Make the Button LongClick event fire after 500 ms rather than when the button is released
  • Add missing functionality related to parsing JSON and XML using dictionaries to the Web component
  • Fix an issue where WebViewString is not set when a webpage initially loads
  • Implement the missing join with separator and string reverse blocks
  • Fix a bug where JavaScript prompts were not displayed
  • Fix an issue where the YandexTranslate component would report a missing API key
  • Add support for dropdown blocks, which is a feature of nb187
  • Fix a bug where multiple calls to TextToSpeech would overlap
  • Fix issues related to numbers not formatting correctly when converted to text
  • Fix an issue where non-text values were converted to text when stored in globals
  • Fix an issue where view constraints were not set up properly when Screen1.Initialize is invoked
  • Fix an issue where URL parameters are not encoded properly
  • Fix some issues related to JSON parsing in the Web component
  • Fix an issue where the random number generator was not initialized on startup, always resulting in the same "random" sequence
  • Fix an issue with drawing shapes on the Canvas
  • Fix an issue related to dragging sprites on the Canvas
  • Implement a missing function (yail/format) that caused some error messages to not appear
  • Fix an issue where certain return values were not converted into lists
  • Fix an issue where JSON parsing would not return dictionaries even if it were requested
  • Fix an issue where CloudDB's GotValue event would not fire when a value had been retrieved
  • Fix an issue where CloudDB tokens would not work when prepended with %
  • Add support for security changes in Chrome 98+
  • Fix degrees->radians and reverse function
  • Fix bug related to clearing Map's Features property
  • Add touch up event after a long click
  • Add the legacy connection pop-up functionality for HTTPS support
  • Add a notification when rotating the device
  • Implement numbers-only for password textbox
  • Fix label font size keeps changing when HTMLFormat set to True
  • Use HTTPS for rendezvous
  • Fix LongClick no longer firing for Marker component
  • Implement the Navigation component for iOS
  • Fix LineString not appearing when setting the Points property
  • Fix issue with resetting counters after using Fill Parent

The release is rolling out over the next 7 days to iOS users. Please let us know if you encounter any issues so that we can add them to our bug tracker.

Evan W. Patton, Ph.D.
On behalf of the MIT App Inventor team


Note: I have not yet updated the iOS build server to reflect the changes approved by Apple. I'm hoping to get those changes deployed by the end of next week.

Hello Mr. Patton,
About the posibilty to build an application package for IOS with App inventor, have you news from Apple ?

I just updated to 2.64 with my iPad but i found more bug with the map features:

  1. I set the map's the CenterFromString, but the map can always show Center from MIT location.
  2. I try to use "call Map.PanTo" and set the correct latitude and longtitude (in Asia), but the map went to a different location (in Africa)
  3. I use LongClick the map's markers / circle to open another screen with startvalue, but it cannot get the start value. And it will just disconnected without any prompt (that is, the popup window will auto shutdown without notice). And sometimes it will shutdown the App Inventor App in iOS

Other than that, I also find some errors like:

  1. security error if changed to another screen in to editor and disconnected again.
  2. app shutdown if change screen.

Still finding more and more bugs with using it.
Don't think this is a good way to use the special popup windows.

Please attach a project file so that someone from our team can take a look at these issues.

GS_EndangeredSpecies_complete.aia (105.6 KB)

I have been testing your app and here is the screenshot after initial load. It seems to mostly match the appearance in the designer view in the editor. What steps should I take to get the behavior you were experiencing, and which iOS version are you testing on?

iPad, iOS 15.5

The coding blocks I created cannot work properly in my iPad

  1. The screen go to Africa instead of the CenterFromString I set in Asia
  2. There is a marker in the circle. After showing the Infobox, the marker disappear
  3. When I long click the circle, it should pass the startvalue and go to another screen. But the next screen cannot show the content properly.

And I already cannot debug with it again.

I create this app before version 2.64. It can work more properly in the old version. But now it crack most of the function.
I need to use this to teach my students. It really bother me if I can teach with this or not.

I tried to re-build the app again from zero, and I find that some problem already happened when I tried to use "open another screen with startValue". There is no problem if I use "open another screen" (without startValue)

And so, when I use the map component in iOS, no matter what CenterFromString I set, it will still show the map with MIT in the center

I've been able to replicate this issue somewhat consistently. Now to work on the fix...