MIT app Inventor for iOS Version 2.64.4 in TestFlight

Hello App Inventors!

The MIT App Inventor for iOS companion app version 2.64.4 is now available for beta testing. If you'd like to help us beta test, please use this link.

This update contains the following bug fixes and improvements:

  • Fix an issue that prevented the min on list and max on list blocks from working
  • Fix an issue with Maps defaulting to the Atlantic ocean
  • Fix an issue where LineStrings, Polygons, Rectangles, and Circles do not appear on the Map
  • Fix reseting of layout constraints when switching projects
  • Make the TextToSpeech component stop speaking when switching screens
  • Add the Spreadsheet component
  • Add more layouts to the ListView component
  • Add DefaultFileScope to Screen
  • Add more features to the WebViewer component

Evan W. Patton, Ph.D.
Lead Software Engineer, MIT App Inventor


The beta version has been updated to 2.64.4 (3). This version implements some missing blocks from the ListView component.


The beta version has been updated to 2.64.4 (4). This version adds initial implementations of the Barometer, MagneticFieldSensor, and ProximitySensor.

Note that due to limitations some APIs, some of the sensors report binary information rather than a full range of values.


The beta version has been updated to 2.64.4 (7). This version includes the following bug fixes:

  • Fix an issue with old rendezvous server WebRTC support
  • Make Clock component support the same datetime formats as Android
  • Fix an issue where centering components on the screen was broken

The beta version has been updated to 2.64.4 (8). This version should fix the MakeInstantFromMillis crash.


Doesn't work at all anymore.

Could you clarify what is happening on your end? This is what I see in my test cases:

I tried it yesterday on both servers:


On both servers the connection breaks down after 20%. I then tried with Legacy, also unsuccessfully. However, this morning, I got it working, but only with "Legacy". By the way, I also tried it yesterday with a practically empty project (just one button). (I've never had to use Legacy before.)

Now I'm just realizing that I have to use Legacy for Android too, because the connection otherwise drops after 20%. As I said, I have never had to use "Legacy" in over 10 years, neither for Android nor for iOS projects.

(I'll try resetting and rebooting everything later, using another PC/Mac, testing it with other mobile devices.)

1 Like

Resetting, restarting and changing devices did nothing. It actually seems to be due to the last Firefox update, because I don't have the problem with Chrome.


Version iOS: 16.7.1 with iPhone X also not connect. I tried in both servers (normal and iOS) and whith Chrome and Firefox. For me is not possible the connection with Companion 2.64.4 (8) in TestFlight.
I don't test connecton with Legacy.

1 Like

With Legacy Connection also is not possible to connect for me.
I tested in Firefox v 119.0 (64 bits) and Chrome 119.0.6045.106. Boths have the last versions. Is not possibel to connect dwith this version.

I am using Firefox 119 and am not encountering any issues. If even after upgrading to the latest Firefox you are still having issues, please open the browser's developer console, right click in the console and select "Save all messages to file" and then PM the file to me.

If you have any browser extensions enabled, it would also be good to temporarily disable them (or use private browsing mode) to minimize the potential for interference while trying to debug the issue.

I haven't tried it yet today, but yesterday both the latest Chrome and the latest Firefox failed to connect. Not in Legancy mode either.
Apparently it works with some older versions. So they probably broke something in browsers again

1 Like

I have tested now over Firefox 119 and at 20% the connection stop.
I have not Extensions in Firefox.
The Phater Process error is:

I send a PM with the Multiporcess Console Firefox mistakes