MAC Sonoma - Emulator Won't Launch M1/M2

I'm using a macOS Sonoma 14.4.1, M2 2022 Airbook.

When I run the installer, I get a folder in my applications folder after I restart. In the folder there is a 'commands-for-Appinventor' and there are a number of EXEC files, but no actual APP installed. Does Version 3.0 this work on an M2? I'm guessing, no since even though the installer finishes, I don't get an actual app. I have done all the troubleshooting steps to no avail. Also, when I 'connect' to the emulator, I get a message: 'Starting the Android Emulator Please wait: This might take a minute or two.' and this never goes away e.g. I let it sit for over an hour, but nothing happens. Thank you for helping me with this issue.

What you installed was a test facility, useful only in connection to an actual Project at

I downloaded the 3.0 version from the following link, and received the issues as mentioned in my first post.
Installing App Inventor 2 Setup on Mac OS X.
The link you provided me directs me back to the same 3.0 version I already tried to install. The installer finishes, but I only get a folder in my applications folder per my previous post.
Also, I have a a project created here : (not putting the full URL in this post, as FYI)
Can you help resolve the issue where I try to connect to the Emulator inside of my project, I get the small window that tells me 'This might take a minute or two.' In your response you reference a url related to the companion app,which I don't need. I'm looking for support on the Emulator. Can you help?

The emulator package published on the website is only for Intel based Macs. I have been working on a version for Apple Silicon Macs but unfortunately there is a bug in the installation script that I still need to iron out before we can deploy it. We will announce a beta test in this forum once it's available.

I use Geny Motion free version.
You can also give it a try