Mac Emulator problem

I am having the same problem w/ an M1 2020 Macbook Air, OS 11.7 Big Sur. I reinstalled the emulator and aistarter is running and listening on port 8004, but it goes for infinite time saying 'this might take a minute or two.' I tried it on Chrome, Safari, and Firefox. Same result. Is there something else I can try? Is there a log file I can look at? Is there an uninstaller? Thanks.

I posted this as a reply to an old post (though to the newest one I could find on emulator problems) and am not sure how / if / that it is visible. I have checked and tried everything suggested in the responses (though many of the old issues seem to be with the PC version). At one point, the emulator worked on my Mac (though I haven't tried to use it since during remote teaching and learning). I appreciate any help you can offer.

– dcp

M1 2020 Macbook Air, OS 11.7 Big Sur.

Oh, looking in the emulator directory, I don't see a version for the M1 or M2 Macs. Is that what is going wrong? Is there a way to run another emulator? Thanks.

– dcp

@PSB_David_Petty

Hi Dave,

Since you're on a M1 Mac, you'll need to follow another approach. Our emulator package only works for Intel Macs at the moment, but it's built on top of the Android Studio emulator package. You'll need to do the following:

  1. Install Android Studio
  2. Install the M1 emulator support in Android Studio
  3. Create an AVD using Android Studio and boot it
  4. Install the MIT AI2 Companion by downloading it from here and dragging the APK file into the emulator
  5. Select Connect > Emulator from App Inventor to connect to your emulator instance running from Android Studio

Regards,
Evan

1 Like

Thanks, Evan! I will attempt.

– dcp

That worked! I wrote a how-to for my students.

– dcp

How inspiring! I've made tutorial video for my students as well. I post here to contribute back. However, there are some hacks to run App Inventor 2 (at least on my M2 Pro laptop).

Tutorial video by me:
https://www.youtube.com/watch/?v=VqzmdORyooM