Local Instance MIT App inventor Not connecting

Hello Guys I hope everything is alright with you :wink: I'm Using MIT App inventor local instance compiled using ant command as usual everything works just fine except Companion not connecting even though I checked the Legacy connection note that It is working just fine until I add some assets (extension or something ) I tried every possible that I'm aware of to fix it but No Success ...Thank you Very much Dears

Did you reset the connection after adding files and then reconnected?

Yeah It is the same Result if you have any suggestions please Help the problem occurs when I Upload anything to the server

Maybe caused by a firewall or antivirus ?

Neither antivirus nor firewall are ON and When I use the offline version of Rumiro AND original MIT (online) It is working normal

Maybe this might help

On master, assets are now loaded by the companion rather than being pushed to it from the web browser. You will need to use -a when running the dev server to listen on all IP addresses and then point your browser at the network IP address of your computer to access App Inventor. The App Inventor service will send this IP to the companion, which will use it to retrieve the assets over the network. By specifying localhost:8888, the companion ends up trying to access a non-existent service on the phone/tablet running the companion, which is why you get the error you see in the screenshot.

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.