Large disappearance of blocks with error The Blocks Area Did Not Load Properly

I have opened my laptop today to work on my project to find it had become corrupted. "The Blocks Area Did Not Load Properly. Changes to blocks for screen BooBarBaz Will not be saved"

However in addition to not being able to make edits I had about half of my blocks no longer present in my screen. Luckily my most resent changes were still present and most of my previous data is saved in my previous checkpoint.

The recent changes were saved however the issue of deleted blocks made in the past and blocks not loading properly did not happen until I opened it up this morning.

Suspected Culprit:
I have Mit App Inventor open in two different browsers. Chrome first and then in Firefox developer. I was not bouncing between the two but I may have left chrome's AI2 open. I did not ignore any warning's for multiple sessions open that I recall... if the message did pop up I would have said to continue with one version only on Firefox, but I don't think I had any warning.

Other potential culprits:

  1. My last added extension I tried to add was the Block Finder as found here
    Find Blocks - Blocks Finder - Guides / Resources - Kodular Community

However this extension proved to be unsuccessful to me and did not show up at all after following steps. This is why I installed firefox to see if I could get the blockfinder to work on firefox. On Kodular I have a pending post in this topic to share my unsuccessful attempts. However I did continue to program and make changes from Firefox on AI2 for a few hours.

  1. When I was trying to check if a Dynamic component existed I made some faulty code that basted my screen with error messages. When AI2 says it will not show another error message for 5 seconds was misleading as the error messages was loading very rapidly on both laptop and companion. The errors was so bad on companion that the phone became unresponsive and continued an ongoing vibration (a short vibration is a command in my AI2 code), volume buttons and phone screen off button did not respond. I had to restart phone and had no apparent issues continuing attempts to fix code after restart. I have a pending post of Kodular sharing snippet of the faulty code to diagnose (excluding the For Every Until loop).

What do you think caused my error?

Help I need now
I need to combine code from my previous checkpoint and code from my current version. I have tried to open 2 projects in two different tabs and copy-paste from one tab to the next tab. This is unsuccessful- does not work. How can I combine code from 2 different projects?

I found resolution here: How can I copy/paste or insert a blockcode from one project to another? - MIT App Inventor Help - MIT App Inventor Community

Related Concerns and Questions:
If I keep to one browser do I need to be concerned about data loss? I am rather alarmed half my code can just be unexpectedly wiped out. How can I proceed without fear of data loss?

I am wondering if treating AI2 as a competent program to make complicated apps is a mistake. It doesn't seem to be built for complex use and I am wondering if more and more unwelcome surprises are awaiting me trying to use AI2 in unexpected ways. However I feel for making a complete project as just a hobby I would like to avoid having to learn to type code. Any opinion on this matter? Also is it possible to convert my AI2 code into code of another programming language? If I do decide to learn another language I would like to study the code equivalent that replicates the same logic from my own program which I already understand very well. I think it would be easy to learn the syntax of another language if I could just study it side by side with the block code I already understand.

DATA Loss Update
Once again lost data. This time I had an app running in companion mode and I went to view old project. This caused all changes in blocks for last several hours session to be lost. Don't navigate projects when companion mode is active. Tip toe tip toe and cross your fingers.

Attachment discription: 1. Error message <Screenshot (6)> 2. Corrupted File <HeroesDiscovery_Dynamic_NotSaving.aia> 3. Previous checkpoint of file without error <HeroesDiscovery_copy.aia>

HeroesDiscovery_Dynamic_NotSaving.aia (6.0 MB)

HeroesDiscovery_copy.aia (6.0 MB)

yes, you should not do this
as soon as you are aware of this, close both windows and restart App Inventor in only one browser


If it help no errors in this one HeroesDiscovery_Dynamic_NotSaving.aia (6.0 MB)

1 Like

It looks like the missing blocks came back! I had taken care of most of the missing code already but there's still some missing blocks recovered I will likely use.

How did you fix it?

Sorry for late reply..

For some reason you had join block attached to piece CONTAINS_ANY text block which is not possible and hence the error.


P.S. I just edited in Screen1.bky file the content CONTAINS_ANY to CONTAINS


Hi, I also had my blocks disappear with the same error message. I came back to my computer after leaving app inventor open. I started working on the app again, and then it reloaded my project and that's when the error appeared and all of the blocks disappeared. Is there a possibility of getting mine back as well?
Aldi_List.aia (78.6 KB)

Try this one Aldi_List.aia (80.4 KB)

That works. Thanks! Can you give me an idea of what went wrong with it?

You had a block of an extension which was not present.

Thanks again. I was suspicious it had something to do with that based on a different post I had seen. I tried to follow the directions to fix it but must not have understood the instructions.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.