Kindle Fire 8 not connecting to computer


I just built a Project a while ago using a fast network and a Tablet. The loading of the Project was S L O W. I just tried a minute ago and the build was IMPOSSIBLE. I closed the browser, opened the browser again and went back to App Inventor and successfully built, albeit slowly. :cry:

Sorry your students are having issues too.

Something has happened since the weekend

  • In many places, online learning has started (replacing classroom learning), stressing the Internet
  • while your IT department indicates the problem is not on the school network end, there is a problem at the MIT end ... developer congestion. MIT does what it can. You might try the alternative server at . Have you tried that? Sometimes the code... server's load is less than the main server. If you use it, students will have to load their current Project aia file on the code server.
  • Are your Kindle's using the latest Companion? Your students should be using Companion 2.60 . Having the latest Companion might make a difference.

I tried the code serve and am getting the same problem. I checked the kindles are on 2.60. I'll keep messing with them and see if I can get something to work.

Thank you!

I just went here , This page shows the number of active users today at 79 thousand. This is a very large number of users for this time of the day. I expect the issue is very heavy usage of the MIT server.

Unfortunately the code server is not ameliorating. Thanks for trying.

MIT just added 3 more build servers to the mix, for a total of 15 8-core machines. I am getting better performance and your classes might too.

Did this help?

That didn't help I'm still not getting a connection to the app. It will load to 20% then lose connection when it looks for a secure connection. I know my speeds are good in way of wifi but still having the issue.

I asked one of the MIT developers to see if he has any ideas. It might take a while for him to respond.

1 Like

Buildserver load doesn't affect Companion connections.

  • Are you using "Legacy Mode" or not?
  • If you were not using "Legacy Mode" does using Legacy mode work for you when non-Legacy mode doesn't?
  • Did the IT folks make any change in the network configuration between when they worked and when they did not?
  • Did the tablets take an update?

The answers to these questions may help diagnose the problem.


I have tried legacy mode, but when I turn it on, it does not do anything. - I could be using Legacy Mode wrong.
My IT department said nothing has been changed on the network.
The Kindle was updated before we started using them. It is currently on Fire OS which is what it was shipped with.

This certainly is frustrating. Using Legacy Mode is simple, when using Companion to scan the Qr code, check the Use Legacy Connection box (just below Version: 2.60 ). When I do that, I do not notice any difference in performance. According to MIT, checking it immediately before connecting using Companion makes a difference on some networks. Evidently it is not a panacea for your issue Mitchell.

Have you taken one of your Kindle's home and tried it on a non-school network? When you use it to connect from your home Internet, how does the Kindle perform? Do you have a different brand tablet or cell? I would try using it to see if there are still issues. Why do this stuff? To eliminate the possibility there are issues with the Kindle hardware or the issue disappears when using a non-school network.

Some other ideas.

  • ask your IT department to whitelist .MIT.EDU ; another teacher related to us that their school IT group solved a connection problem for another teacher.
  • do your tablets have an aggressive virus checker?
  • developer activity is significantly less today than the past several days ... your students might be able to compile now.


Thank you for all your help. I connected my tablet and laptop to my hotspot on my phone and they worked just fine. I think that my schools firewall could be blocking the ports the program uses to communicate with the devices. Does anyone know the specific port numbers App inventor uses?

Appears you are making progress.
Ports 8001 and 8004 if using Legacy probably. The normal connections are dynamic when not using Legacy but might require port 3478 ... see the documentation below. The IT people probably would have to whitelist the .MIT.EDU domain.

This advice should help * School IT/Network Admins: Information specific to school networks (also helpful for conferences and hotel situations) . However your IT group says they did not make any changes over the weekend.

Have you tried using the USB cable method to connect as indicated in the above document. You shouldn't need to do that in my opinion but maybe you do.

How about using an AI2 offline version?

Can I use my tablets with this?

Mitchell, AI2 offline is NOT maintained by MIT. The way I understand this is that it would have to be installed in each of the computers your class uses and then you could use it with your tablets.

I do not expect Anke's well intended suggestion is a solution for your class. Evaluate it, but the connection problem appears because of the school network and heavy usage of the MIT servers. You proved that when you used the Kindle with your hotspot.

  • AI2Offline_nb185a.7z (180MB) (download e.g. from home),
  • save it on a USB stick,
  • distribute in class / school,
  • download and start AI2Starter →
  • connect Kindle / tablet via USB.

No internet / network connection required.

Note that if you want to use the USB cable instead of the Wifi option, you can still use the online version. You just need to install aiStarter on the school computers and use the USB option from the Connect menu (the last two items from Anke's list).

As Steve mentions, only the online version is authorized by MIT. Any offline distributions are not provided by us (App Inventor is open source, so anyone can compile a copy). If you do go down the offline route, you'll want to make sure you are backing up project data as well.

We got it fixed. we had to create a hidden network for my classroom. Thank you to everyone that help!

Great Mitchell. Thanks for letting us know it was a school network issue solved. :slight_smile: using a 'hidden school network'.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.