Error 1103 - After updating to Android 10

I received error 1103: unable to post or put the text when I tried to connect to AI Companion after updating to Android 10.
I don't use any Web component and previous projects(they worked) don't work now. All of my projects occurred the same error message.
This is the error message.

I tried following:

  1. Try to reach from my computer. -> OK!
  2. Try to reach from the phone itself. -> OK!
  3. If the steps above both work, try using the "ping" command to ping to the IP Address of the phone -> OK!
  4. If all of these steps succeed and Wireless App Inventor still doesn't work, then there may be a firewall between the computer and phone -> No firewall.
  5. Checked using the same wifi of computer and phone.
  6. Removed and installed MIT AI2 Companion app again.
  7. Rebooted my computer.

What else can I do?

Companion version?


Try to connect via USB.

Look here for the Companion version on your phone:

This is my companion version.

Companion version is 2.60.
Thanks for your suggestion.
I will try to connect via USB, but would like to fix this problem.

Attempt to run your code in the emulator. If you use the emulator what happens?

Do you use extensions? You may have an extension incompatible with Android 10.

Emulator is working.
I don't use extensions, tested a simple app like just using button.

OK. Some progress. This means the issue is either with your hardware (OS 10) or connecting with Companion using WIFI.

When you use Companion, do you log into the the main MIT server ( ) when you get the error message?

You could check the box on the Companion screen Use Legacy Connection, and see if that option allows you to post or put text.

You could try your Web based app in the emulator. It might work.

If nothing else works, you could post an aia of a simple post/put Web app and others could try on their Android10. Sorry. I only have an 8.1 Android.

Yes, I got the error message when I log into the main server( Actually I don't know other severs.

Nothing happened(No reaction) after scan QR code when I checked Use Legacy Connection option in Companion. But I got a connection fail message in my computer.

I made Web based app, It works in the emulator.
I will share aia of the app after finding how to share it.


Please, Test this app if it works in Android 10.
Thank you in advance.

WebSearch.aia (1.8 KB)

Yes, and also on Android 11.
Try this server:

... or an offline version of AI2:

Thank you for the information.
Unfortunately, I got the same error message on the server:

Ok, then try the offline version.

And try to connect to Kodular:
If you have the same problem there, it may be with your device / WiFi connection.