Issues loading SQLite Database

I am trying to use a simple database which I plan to use to display data on the screen. My first goal is to load the database then have it pull items into a listpicker.
I cannot seem to load it, i always get an error stating there is "no such table" it appears that it is not actually loading the table as it is only shows there is 1 table, the android_metedata table. I am using the Pura Vida Apps SQLite extension

What is the exact error ?

Do you get the same result if you don't use the addons extension:


and are your columns and tables all in upper case ?

It is the same error if I use the addons extension, my tables are all in uppercase, and the exact error is:

Error: no such table: STANDARDS (code 1 SQLITE_ERROR[1]):, while compiling: SELECT STANDARD_NUM FROM STANDARDS;

what happens if you try the example project?
which device and Android version are you using for your tests?


Trying to push the limits! Snippets, Tutorials and Extensions from Pura Vida Apps by Taifun.

I actually get the same error.
I have a Samsung S9+ with Android 10

Upload db.sqlite here, so it can be checked against your SELECT.

In companion on Android 10 I can't get an sqlite to import from the normal assets path:


but it does work with a full path:



Here is the file, I had to at .txt tot the filename to upload it.db.sqlite.txt (57.8 KB)

I'm still getting the same error trying it this way.

the sqlite extension needs a quick update because of API 29 for Android 10 devices...
the companion app is not able to import the file anymore from the assets. It still should work after building the app. I will provide an update tomorrow morning. Please be patient meanwhile...

the following path should work for the companion app meanwhile


the sqlite extension has been updated now
you can download it from the download folder
before using the test example for your tests, you might want to clear tag FIRSTRUN from TinyDB to be able to import the example database



Thanks for the quick fix @Taifun :+1:

1 Like