Install an APK after downloading to ASD - works on all Android versions

@Anke. Same Error.

The urls are the same. they are copied.

No, the screenshot I posted in post #81 is from your aia (post #80).
So check it again. I checked it on Android 12 (Companion) with the correct URL and it worked fine.

I have the same problem on Android 11, download finished, but the apk size is not correct.
I'm using your Instalacion_2.aia

Where from? Show your blocks (especially the URL).

this the url

I'm sorry, but I did not understand

Read the whole thread and you will understand.

Thanks for the help, I give up

Where is the problem in renaming the APK from e.g.
myApp.apk to
in Google Drive and then download this file (as shown in my link)?

sorry, I'm also confused...
@Anke are you saying, your solution is only able to download png files?

I tried to download a real image with your block, the image were downloaded but it is corrupted

Post the aia or send it to me via PM.

This is the aia
Instalacion_3.aia (25.8 KB)

with companion I can download the apk, the size is correct, but I can not install it by companion, building produces this error:

Try this one:

Your apk runs well, but where is the issue ? My aia was correct?


Obviously not. So create a new project with my blocks and try again.

Why not correct ? I used your aia in post 78, I don't see any substantial differences between the 2 projects, anyway a new project runs well.

Fine, then something went wrong with your (old) project.