Install an APK after downloading to ASD - works on all Android versions

I don't understand why that appears. The link is to a drive folder where the apk is

@Nacho It should link to a file, not a folder:


And after that you need to set the direct link, as shown above.

Thanks a lot.

You were right. When I have uploaded the file to another download platform it has worked great.

1 Like

In my app I use a canvas and by default it asks for read and write permission, however the app does not use this permission for anything else, so I have manually removed the two lines with apk studio as you mentioned in another thread.

You say that the extension doesn't need this permission, but after doing this modification the extension doesn't work for me. Can it be related?

This problem regarding WRITE permission (for Canvas) has nothing to do with my extension. My extension definitely doesn't need any permissions.

See also here:

If you will use google drive to keep your apk up-to-date, you don't need a file download extension at all. You can install the apk directly from the google drive, also without permission.
Test what I wrote about a few posts above.

1 Like

Yes, I got the information on how to modify the permissions from there.

As it was clear, your extension does not need permission, however I was trying to update an app that had the permissions with another app to which I had removed the read and write permission. And this seems to be incompatible to update.

Of course your extension works fine.

Uploading a renamed APK from myApp.apk to myApp.png works also with GoogleDrive:

Hi @Anke thanks for Your Extention
I am trying to create an in app update system.
I use your Extention but I am facing this issue

My blocks :
Value in my Firebase

Can you tell me the is problem is In my blocks or Firebase value
& 1 more thing I want to know is there is any method to Install updated apk automatically without need to delete old app?

1 Like

Hi @Anke,

Thanks for your extension. I used version 3 of your extension on App Inventor nb188 with Companion 2.62 on Android 10.

the block on my application is like below.

when I call the procedure of installAPK on my App, the download started well, and then it was completed successfully. And I can see the file in the below folder.


Also, I can say that DownloadCompleted event is started well due to ShowAlert command is giving the below message.


But Installation doesn't start automatically. I checked if installation could be start manually to be sure the downloaded file doesn't corrupt. Installation can start if I start it manually.

I would be very grateful if you could help me.



1 Like

I checked it again. After downloading the APK, I see this:


So where is the problem?


1 Like

In my opinion you too are an Expert :grinning:

You've made many many extensions till now :grin:

Thanks @Anke,

Thanks for your quick response. I tried it on the new project. And I tried 2 way.

  • using it by AI Companion

  • Using it by building apk and after installation on the phone.

while it works well by building apk and after installation on the phone, it doesn't work by AI Companion.

Then I used it on my original application by building apk and it worked.

Thanks again.


Dear Anke,
I'm a young novice student, sorry but it's my first time on this platform and I got a problem with the version 3 of the extension.
I can download the apk but it shows an error, and even if I can find the downloaded apk, I see that also the file's size is wrong so I can't open it.
I've already read similar problems in this community and checked e.g. I linked a file and not a folder..
but I don't know how to make it works.
I share the error screen and my blocks.
Thank you in advance

Did you rename the APK to <yourApk>.png before uploading to Google Drive?

As shown here: