Import of TaifunFile Extension Failed!

I tried to update on AI2, TaifunFile extension but I get this error:

An extension containing com.puravidaapps.TaifunTools already exists on the server but could not be upgraded. The new extension was not loaded.

ops... I now notice a discrepancy... why am I updating TaifunFile and the error show TaifunTools? I have both but i am trying to update TaifunFile...

Some idea?

1 Like

Can you show what versions of the extensions you are using?

This was the answer from Taifun from an old Google Group discussion where someone had the same problem.!searchin/mitappinventortest/taifuntools|sort:date/mitappinventortest/ORsl9PwjjKU/azCrDst0BAAJ

the file extension is a very old version, which unfortunately does have that issue
this was fixed with version 5b as of Aug 11th 2016

you have 2 options:

  1. keep the extensions as they are, or

  2. remove the extensions including losing all corresponding blocks, then add the newest versions of each extension again and redo your blocks
    you might be able to copy the blocks to the backpack to not have to do everything from scratch


Open a new project with the new TaifunFile extension and the project with the old extension with e.g. 7-Zip (no need to rename aia to zip):


Thank Peter
TaifunFile from extension 11 to 12

maybe I choose 1
Best regards

Thank Anke
this is a good idea
Best regards

I don't know if it really works or not but you can try this:

  • delete extension
  • import extension
  • right click in blocks editor
  • click on undo

You can also try FileTools. :grin:

This is not just an idea, I have often done it myself.

I tried the instructions for updating th extension inside the AIA file and it worked perfectly.

Thanks for the idea.

Yes, as suggested in post #3. This topic has not been closed since August 2020. I've done it now by marking the correct answer as the solution.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.