I need help with this error code, I'm using a kindle fire and a chromebook, I get this when I try to connect to my app


Make sure your Companion is up to date.

I'm not sure how to update it on a kindle, other apps work, not this one

You need version 2.66 or 2.66u

How did the Companion get onto the Kindle in the first place?

I'm not sure, this is my teacher's kindle

If you use the Back button in the Companion's currently running app, or start the Companion fresh, you might be able to show whatever version that Companion is up to.

If it's less than 2.66, this is something your teacher should be aware of and hopefully get fixed.

Be polite.

its 2.64 from what I remember, I'll try to get it updated, what does the error code mean? if you know.

The error code is a side effect of trying to mash together two mechanisms that don't exactly match.

What you see is spilled Java guts.

how recently was 6.6 released? if I made an app before this would that be why it still connects?

When I make a brand new app, it works, but if I copy the app that's having trouble it does not

Working across multiple versions is too hard for me to handle.

I would concentrate getting that Kindle updated.

I ended up getting permission to use my phone, less of a hassle I guess. Thanks for your help!

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.