How to solve error 1101 App inventor?

Hi, can someone help me to solve 1101 error.
my project is an robot and i use app inventor to control his movements. Icreat motion functions in arduino. cnection: wifi

"v" go left

"s" stop

Use Screen Error Occured block

1 Like

If you want to get rid of this error message, try this:


If the number is 1101
then... what should I add?



I tried this, now I don't get the error as a text, but... it still doesn't do the function I want it to do

1101 = unable to get a response
So if you get that error, then there is a problem with the connection...

This solution only ignores the error, but is not able to fix it magically sonehow...

in this case you will not be able to control the robot anymore... the question is, why do you not get a response anymore? Are you probably out of range?


Thank you so much for your response. I'm sorry, I don't understand what you mean by "out of range," but I'm going to explain more about it, and I hope you understand what I did wrong with my program.

Firstly, my robot has a small car-like shape, so it needs to perform movements like turning right, left, going forward, and backward. To achieve this, I used Arduino blocks. It's important to mention that the motors I used are 360º servo motors, where 90º corresponds to a "STOP" state, 180º means "go forward," and 0º means "go backward."



In the App Inventor, I want the following functionality: When I touch the button, it should trigger the corresponding action (left, right, go forward, backward), and when I release the button, I want the it to stop.


Does your phone connect through

  • local WiFi, or
  • through your cell phone carrier?

Can you reach that URL from your phone's native web browser?

my phone connect through my house wifi

I get the PIN by Consol (arduino)

Yes or no?

1 Like

I guess no..
how can I reach it from my phone's web browser?

Searching for local ip address elicits these community discussions. You might be able to access using methods similar to these: Search results for 'local ip address' - MIT App Inventor Community

I dont know but i notice something
the IP in my app in my phone is different that the one in arduino

WHen you hear about a new site you want to visit, like, you type it in to your phone's search bar using the phone keyboard.

Do that with your URL.


This is progress.

Now the problem is reduced to figuring out why your phone can't reach that IP address.

Rummage around in the Settings app, in the networking area.

where exactly?

Look for more details on the WiFi network, in case of surprises.

Also inspect the VPN section.

Come to think of it, show them all.

Each might be surprising.

is it wrong to have no VPN networks?