How to request and grant MANAGE_EXTERNAL_STORAGE permission

In both cases. You have to check the API level of the device, because MANAGE_EXTERNAL_STORAGE permission is only relevant for Andoid 11+.

Thanks again to Anke for allowing me to continue using my apps with minor changes

Hi... Does this aix can kill mock location permissions on other app?

so my app will use real locations when I use my app...

even the fake gps app is set and active...
Thanks

First, I don't understand the question and, second, what should storage permissions have to do with location permissions (and then even with another app)?

Ups... Sorry... I read it allfilespermissions and i assume it include to control mock location... :pray:

Thanks...

Hello
I'm new on this forum,
I wish you all a happy new year !!

Congratulations to Anke for your investissement and your work !!
I'm testing your extension, and APK example but ...
Your APK works fine on my mobile but mine no, and i don't know why and need help, please :sob:?
I attach my aia file.
I can only save in the app folder (filename without a "/"), if i start filepath with a "/" i have error 908 "Write external storage denied".
I test with the 2 checkbox checked (read/write permission) for file compoment but still the same.
Could you send me your aia file or help me ?
Thanks a lot !!
Goog end of day
Hugus
AnkeExt.aia (6.5 KB)

set default file scope of Screen1 to legacy (designer mode)

2 Likes

Yes, as @patel said:

grafik

Hello,
Perfect !!
Thanks a lot !!
Good day
Hugus

1 Like

Fine, next time, please read the description first:

1 Like

Yep !
I read it but thought it was for the file component not the screen !
Sorry !
Thanks !
++

1 Like

2 posts were split to a new topic: I'm having problems with the file system/file structure on Android/AI2

A post was merged into an existing topic: I'm having problems with the file system/file structure on Android/AI2

Hey sorry for late writing, this is my first posting.. I read about but with android 11 and the original appinventor2 v 30, by setting legacy, even only in the blocks, I can copy a file from public directories (/Downoad/any/) to private app space and viceversa. But but, when I build my app apk it cannot access anymore, denied access to external storage ecc. It is not a filename problem, it seems a permission problem. Setting it in screen1 designer also dont work. Apparently the apk has multimedia write/read premission... the file is a simple text csv file..
Before going crazy, is there a possibility for an apk built by appinventor2 v30 for android11 to copy a text files to/from public storage?

sorry for my preceeding posting, just now I found the tutorial Some basics on Android storage system - #13 by Anke and probaly understood why under appinventor share access worked, and the fact that read access to shared folder is free granted only for files created by the app (appinventor..)
boh.. are not these limitations rather excessive?..just to import some list into an app is a pain..

Yes thank you! Now i have to check deleting appinventor created files in the shared dir (/Download/..) because they could deny access to the same files from the apk which is a different app!

1 Like

there's something wrong... according to your https://community.appinventor.mit.edu/uploads/default/original/3X/4/0/40cd49dd497957af9973789392bc0b679d1ca8f6.jpeg I should not need any permission to write and read a text file generated by the app from /Download. In fact testing under appinventor it does ok!
Building the apk, when reading if there is no file, the app stops telling "file not found" but if I hand copy the file into /Download it stops telling "no permission.."; and that's also ok.
But when writing the text file in /Download (where is not yet present) the apk stops, telling "no external storage permission granted ..etc" ; that's not good, I should not need any permission to do that so why this message?
Furthermore, the scope should only set the default base locations, on android 11.. You said to set screen 1 scope to share or legacy, but apart setting the correct path (which in my test is ok) I don't need any permission..
So, I fear it is the appinventor builder itself (and not android 11) which is forbidding.. As said, under appinventor testing I can perfectly write and read the files from /Download


you found one of the bugs of the file component
@ewpatton my guess is, this bug is already on the bug list of the file component?
@roby_nooorano you might want to use

Taifun

1 Like

If not, my countless reports on this bug would not only have been unsuccessful, but would have been a complete waste of time.