How long does it take for the error to disappear?

Hello, for about 2 hours now I just can't continue working on my app, I have no idea why but no matter what I do I get a pop-up "oops an error occured" all the time since I tried to duplicate a component on my store screen!!!!!!!!! This is really dumb because I have to turn in my app for a school project tomorrow night. The problem is that I have already started working on it and the error affects the store screen so that you can't see anything except white. How long does it take until this bug is fixed, goes away?

I suspect you made a mistake and the app crashes. Share your .aia project file here.

retroGames2.aia (2.1 MB)

It's not my app that is crashing, it's app Inventor, the website. When I run my app it works totally fine but I can't work when my deigner screen is just white @Patryk_F

The problem is to use the table component, the table component has a bug that will be fixed. At the moment, I recommend that you delete the tables and apply a few horizontal arrangements.

Ok, thanks, I will try it

I deleted the table arrangements in the shop screen, and this version loads okay on the code server.
retroGames2_NoTables.aia (2.1 MB)

1 Like

I have a bit of a time crunch as I said and this really helped me

Does this help?

I had the same problem about a month ago. Solution is to just not use the VA Tables. Make them out of nested V arrangements, and H arrangements.

1 Like

Thank you, helped me in fixing the problem, my error also occured when I tried to copy paste things in a table arrangment, there seems to be a bug. Good luck fixing it @ewpatton ; )

The table is ok as long as you don't paste data there. By hand dragging, it should be approx.

1 Like

Thank you all for your answers, I still have one problem, it has nothing to do with this problem. Sometimes but only sometimes my app crashes when I press the back button in my shop screen. When you click the back button, the ChoosLevel screen should appear but I keep getting an error message: ai2 companionen has stopped. Is this a bug?

Here is a working one retroGames2.aia (2.1 MB) without deleting anything in it..

1 Like

I tested the back button several times and I did not have such a problem.

Ok, maybe it's just a bug 🤷Thanks :smiley:

Notice when this error occurs. Maybe you are doing something not standard then?

No, as far as I know I just always do the same, sometimes the companion app stops, but when I test the app as APK there is no problem...The only thing I do is then just relatively fast "jump" through the screen and maybe that overloads the companion? I Tried it a few times more, it keeps crashing about every second time.

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.