How do I make my own App Inventor?

java_dev_appserver.cmd --port=8888 --address= appengine/build/war/

I ran the command above and got the output:

This action requires the installation of components: [app-engine-java]

ERROR: Cannot use bundled Python installation to update Cloud SDK in
non-interactive mode. Please run again in interactive mode.

If you really want to run in non-interactive mode, please run the
following command before re-running this one:

  FOR /F "delims=" %i in ( '""C:\GCSDK\google-cloud-sdk\bin\gcloud.cmd"" components copy-bundled-python'
  ) DO (

(Substitute `%%i` for `%i` if in a .bat script.)
Installing component in a new window.

Please re-run this command when installation is complete.
    $ gcloud --port=8888 --address= appengine/build/war/

It said to me to run the command when the installation is completed, but when I run that I get this error:

ERROR: (gcloud) unrecognized arguments: --port=8888 (did you mean '--format'?)

To search the help text of gcloud commands, run:
  gcloud help -- SEARCH_TERMS

I have python installed on my computer and my variable values of PATH:


I don't know what is wrong and why the error is appearing. I am using Windows 10, 64 bit computer with 12 GB ram. I ran the make auth key command which was successful and tried again but it was the same.

1 Like

The error is pretty clear, you need to install the Java portion of the App Engine SDK. You can do this by running:

gcloud components install app-engine-java
1 Like

Now I face this error:

Unable to find the webapp directory appengine\build\war


1 Like

Webapp directory is created after building appinventor, make sure you run ant or ant noplay command

1 Like

in the cmd im getting server running but when i open local host its saying refused to connect

1 Like

Hey there it's been a while since I used anything related to ai2 so take it with a grain of salt. So I think the problem could be as simple as using http and HTTPS or even your firewall blocking it so look into that as for me I think I faced ithis issue and I think it was firewall issue but again it's been quite long since I used ai2 so I might be wrong


Do you have a screenshots of the terminal window and browser? There are two App Inventor servers, one is the App Engine part that hosts the frontend and the second is the buildserver. The second is only needed if you intend to testing building apps. One failure mode is people sometimes run the buildserver but not the App Engine piece, which is consistent with your symptoms.

I even started the app engine too.. Can u please send me the most recent topic about the steps to install it locally? Because the even this steps ain't working

Please provide screenshots as I requested. You can always reference the setup instructions in the README:

still the same issue server states running but local host refuses

I'm not sure but, maybe you are running Build server and not the main one.

yeah build server is running , but when i try to run the main server it just opens up git and then shuts down

Yeah, thats the problem, for that you directly open the git and run the command from there, make sure google cloud is installed.

as previously mentioned by ewpatton, you need to run dev server, not build server.

where should i paste this command in the cmd or in the git bash,cause when im executing this git opens and then it shuts down

        --port=8888 --address= appengine/build/war/

Your command has invalid line breaks, try running this command in git: --port=8888 --address= appengine/build/war/

an easy way:
double click this buildtools.cmd to run, all command are there.

1 Like

tried this

ill try

Did you try that in gitbash, or you can just use build tools, its easy :grin: