Having Trouble Selecting The Blocks

Hi I am having trouble with the blocks Some of them I can select but the others cannot be moved to the work area Can anyone explain why Thanks

That is very hard to explain as we don’t now what you are experiencing? Can you show what blocks you are talking about?

Hi Peter See screen shot Now the bottom two can be moved but the three above cannot

Screenshot 2020-02-27 at 08.35.38

I can move all of them. What browser are you using?

Peter I have tried Opera and Firefox

I am working on my Chromebook just now and that just works. Are these the only three blocks not working?

No Peter It would appear when I go to the other blocks some work some don’t I am going to upgrade my app inventor to see if that works 4.6 I think it is Im downloading

Just out of curiosity - what does this icon mean?


1 Like

Upgrade App Inventor? What you see is what you get - always the latest, delivered online. Use Chrome or Firefox latest versions…

It’s possibly a Broadband issue - where are you using App Inventor - Home, Work, School?

Hi Chris Home Never had trouble before so it can’t be bandwidth as I watch moves I will try a update version Thanks

Forget versions, this in the browser.

What add-ons and extensions are you using?

Also, make sure the ai2.appinventor.mit.edu site is allowed popups in the browser.

I can’t understand why some of the blocks move but the majority will not I have tried Chrome Firefox Opera even tried on my andriod phone still no luck Thanks for trying everyone

What happens if you type initialize global to activate typeblock and then press enter? Does it instantiate the block on the workspace? If so, can you drag that copy?

1 Like

Here’s another straw to grab at …

Try using a new mouse.
Maybe your contacts stick?

Like Anke asked, tell us more about shield

Hi It works when I type in Initialise global And I tried Thunkable and all the blocks moved on there Strange Thanks all