Has anyone else has had or does have the error that assets can not be loaded?

@TIMAI2 could I split this into a new topic? I no longer want to ask about connecting. I wish to ask the world if anyone else has had or does have the error that assets can not be loaded.

1 Like

It has happened before and it's usually a combination of factors - the Browser, the capacity of the Broadband and the health of the MIT Server. What can make a telling difference with image assets is to ensure they are no bigger dimensionally than they need to be and of course their file sizes - this is also important for the finished App -too many oversized images for the OS to deal with can cause a crash.

So at your end, ensure you have good, stable Broadband and that App Inventor is the King - don't have other heavy sites loaded in the Browser at the same time and ensure that no one else is taking up bandwidth (watching videos etc). Use either FireFox or Chrome.

At the MIT end, there are peak times when the Servers will inevitably be slower - it can time-out on you. They have been recently renewing the Servers though.


Thank you. I understand bandwidth problems on my end Chris. Those are fine.
No oversized files, in fact it crashes on a 1k html.
The finished app has been compiled and running on my phone since February 10. Yes I was able to connect at that time.
I have tried every time of day and night and on multiple days.
I use Firefox but also tried Chrome.

While this problem exists for the offline MIT and for http://ai2.appinventor.mit.edu/ it NEVER happens on MIT App Inventor

These two errors are always and are consistant and do NOT happen at all on MIT App Inventor

Any thoughts?

Corrupted aia


NO. The aia loads and runs just fine on MIT App Inventor - no errors at all. used it for hours today.

1 Like

What is the path to the html file that works (worked) on code server/ai2 server.

Also show your relevant blocks

[EDIT Oh, this is about actually loading the ai2 program, not a file within your project ....)

This server > http: + //ai2.appinventor.mit.edu/
it will load but not run
it will load but not run
http: + //code.appinventor.mit.edu/login/
it will load and it will run fine

Well if it only works on //code.appinventor.mit.edu/login/, we are looking at a file size issue. What is the size of the Project (.aia) Wes? How many Screens are there? Is the HTML in Assets (Media Tray)?

1 Like

Correct. It loads the aia but gives the red "blocks area" error that flashes less than a second at top of screen
When I attempt to connect the companion it gives the assets error and crashes

I am again going next month into far place from civilization and would like to solve this so I can use offline version

Yes they are in media. 6 screens but only one of them heavily populated.

1,246 kb

about 4k blocks

Sounds like a lot of Blocks :thinking:

Can we see your Project?

you want me to send the entire aia? I would rather not ... personal reasons

Thanks for the compliment @ChrisWard :joy: its my first app

Difficult to know what is wrong with a file if we can't study it.

What you can try is building a APK (and let us know it's size).

APK is 4,504 kb

That's all in-and-around average.

ALL in. Was able to load, run compile it into first week of January.

Went into remote place and returned May 3 but did not use MIT until about a week ago ?
The app I have been using every day since December and so have two of my family.

Oh, so you can get to the ai2 server now ?

No not really. 50 tries in a day and I might get a connection once in 3 days

How many files are in Assets (Media Tray)? We have seen an issue before where the shear number of Assets could not be uploaded before the Server timed-out. It's possible that %code.appinventor.mit.edu is faster than %ai2.appinventor.mit.edu