GSOC'22 proposal Query

Hello, my name is Yugal and I have looked the idea list and there are 2 projects that I find interesting.

  1. Implementing teachable machine
  2. Implementing AR component
    As for my techincal background I am currently learning both android[kotlin] and java. As for my queries:
  3. Are my skills at the level where i can contribute in these projects?
  4. And if my skill level is up to the mark, then how should i get started?

Hello Yugal,

For implementing new components, you will need Android Java, and if it is a visible component, you will also need to be familiar with the files in App Inventor open source. You can get started by playing around in App Inventor GitHub, and check this out.

1 Like

@Adonis Welcome to community.

My opinion on your question..

  1. Definitely Java and Android knowledge is must to contribute in App Inventor but you must have a little bit experience with App Inventor source code, because some things are different in App Inventor.
  2. For Implementation of Teachable Machine you have to knowledge of Tensorflow and little bit of machine learning.
  3. I am already working on proposal for 3D components (I am just sharing for information but if you want then you can do.)

thanks for the reply. up untill now i have only contributed little in some projects, so this time around I am really looking forward to have a bigger part in contribution. And i will reflect on those suggestions and communicate with u as soon as i am complete with that.

after running the below command:

$ your-google-cloud-SDK-folder/bin/
--port=8888 --address= appengine/build/war/

it is giving me some error, i tried google to find the solution but unable to find it. So could u give me any suggestion why is this happening


Where you are running this command? I mean what is your PWD?

You must run this command in appinventor directory.

yeah, i am running it in app inventor directory. And then there i run that google cloud sdk command

Have you installed Google cloud SDK ?

Also rename your directory GSOC'22 to GSOC22. Better not use special characters and empty spaces in directory name

yup, as u can see in the image there is google-cloud-sdk folder

Actually, I don't remember the path of file but you can find in cloud SDK folder then you just need to make sure you are coping path of .cmd version of file if you want to run command on "command prompt" and .sh file if you want to run command on "git bash".

Just drag and drop the relevant file on cmd or git bash and then write remaining part of command and run it.

Well that problem is solved but when i run this below code it is giving me the following error:

--port=8888 --address= appengine/build/war/

--port=8888: command not found

These are some of the errors that I am getting while running the port command? Any idea how to resolve this issue?

You're likely running the wrong version of Java based on your most recent stack trace. Please verify that java -version outputs Java 1.8

this is what i am getting

Yes, you'll need to install the appropriate version of Java and set up your JAVA_HOME environment property correctly.

so i have to update to jdk 18 right?

No, you need to downgrade to Java 1.8. The decimal point is important....

one more thing i have installed so java1.8, so java home should be declared in user variables or system variables ?

Set Path and JAVA_HOME