Getting companion error in Open source

I am getting an error in companion connection in open source development.
When i connect companion it's works perfect without any extension . But when i import any extension than it says Unable to load file:.....

What kind of extension is ? Where you download it

Not an specific extension.
Any kind if extension when i try to import than i get error in all kind of extension

IG, You testing it locally? I believe I had a encountered similar problem few weeks ago.

(although the PC and the phone were on the same network)

If your projects include assets (including extensions), then when you run the dev server you must include -a in the dev server command to listen on all IP addresses and then point your browser to the IP address of your computer on your network rather than localhost. This is because the companion loads the assets by retrieving them from the server. If you have your server as localhost this results in the phone trying to load the assets from itself, which obviously can't work.

Ok I've try

Getting same error again.
Also tried with -a

how do you access your dev server? still localhost? did you try by ip address?


did you read this?

Where i can find ip address

google will tell you the answer

I tried using ip address. It showing white page after login

how? screenshot please

Sir can you share your telegram id if you don't mind ?

sorry no telegram.
Why not ask here.

Because maybe i think i will get the answer slowly😉

this is an open community, other users may learn from this if you post your question/solutions here.

1 Like

Run ifconfig on linux/mac or ipconfig on windows to inspect network configuration.

Other methods on linux:

private/local IP:

hostname -I
ip addr
ip a

public IP: