Gets kicked out

I just notice that I cant initialize global filelist, I cant find it

Please do it like this (with your own directory path):

There is no local variable in my example. You will always get an error because you are trying to get something from an empty list.

Global variables are initialised by themselves, as in my example

Still no luck

What do you from do it here (clear the error first)


are you refreshing your companion to initialise the global variable ?

Cleared the error... and refreshed...

Are you using an Android 10? If so, see related discussion Problem with July 30 2020 Version: nb184 no longer able to write and read files that seems to be related to a bug that affects writing files on Android 10 devices.

MIT are aware of the issues related to that post. It may take a while to fix that issue.

Hi I have android 10.... 2 days totaly ruin shi.... !!!

And of course Thanks to You and a even bigger on to TIMAI2 for the effort... I will try to backdate the phone....

This works on my Android 10 emulator

Don't You run companion... I have tried to uppload my project on testserver but no look so far...

which testserver are you talking about?
are you using the corresponding companion app?


Trying to push the limits! Snippets, Tutorials and Extensions from Pura Vida Apps by Taifun.

The one that is linked in this thread.... (SteveJG) I have downloaded the corresponding companion app but I cant install it (Won't se it)

Ok up an running with the testserver and the corresponding app. but the problem remains... So much work for nothing. I need to take a break now...

There must be something very simple... I mean I cant even use a simple imagepicker.. Se my previous not three Hours ago...

ok, which means this one

please provide a new screenshot of your relevant blocks...
are you using @TIMAI2's method now, which was working for him?


Sorry for my delay but I worked way over my time yesterday, but now I'm back Lets hope a fresh brain will do it.

Well as You se it don't work. It must has something to do with the update because this has worked previously. Now I'm back with standard plattform...

and what error do you get when you click the button?

Hi !

No error...

I have tried some more code and it seems that that i cant get the list function to work...

Please tell :slight_smile:

Same error...Tther previous working procedure failing at list... It's to much "junkcode" that doesnt have with the problem to do so its hard to follow... Give me som time