Gets kicked out

Hi! Problably something very easy The problem started for a while ago with an app that previous worked. It's actually happend when I used call web1.postfile but I found out that that the same thing happends when I try to open the file as a image... I cant find anything wrong with the path and I get no error message

What do I miss ?

Your blocks could be much more simple:

Ok back to basic... tried this

With the same result, kickout imediatelly....

Tried to change the directoryname and than ofcourse the following error


If I atleast got an error message. There must be something with the path or the permission

Try with a global variable for the list, then you can use Do It to see what values you are getting

Thanks But this language is not as them I'm use to so could You please give me an exampel...

The most funny thing is that this has worked before....

To use Do It, run aia project in companion then right click on a component to get the sub menu, Do It should be at the bottom, click Do It and it should return the current value of the component

This is what I got....

and if you try your directory path ? (you may not have any jpg files in your root directory....)

Also you didn't use the global variable in your button click event

My misstake...

In desperation I also tried to add an imagepicker. It works fine to select a picture but it wont open...


Now use the global variable and the directory path you were trying earlier, and show the do it for the Taifun Filelist and the seleced file

This was Removed


I just notice that I cant initialize global filelist, I cant find it

Please do it like this (with your own directory path):

There is no local variable in my example. You will always get an error because you are trying to get something from an empty list.

Global variables are initialised by themselves, as in my example

Still no luck

What do you from do it here (clear the error first)


are you refreshing your companion to initialise the global variable ?

Cleared the error... and refreshed...

Are you using an Android 10? If so, see related discussion Problem with July 30 2020 Version: nb184 no longer able to write and read files that seems to be related to a bug that affects writing files on Android 10 devices.

MIT are aware of the issues related to that post. It may take a while to fix that issue.