Error d8 failed

i got error d8 failed
How can i fix the errror

Did you get any help?
I have the same issue

Doesn't matter which project. For eache project I get the same failer message

Possible to upload your aia here?

Can you also list the extensions you use in your project?

i use custom webview, openai extension
i use firebaseDB and have the error

Yes you can send to me. And do you have this error before? Or just happened today?

I continued to develop my app and upload it, which has always worked without any problems. Suddenly this error message appears and It doesn't matter whether I work with Firefox or Google.
[RunD8]ERROR: D8 failed

I have never encountered this error but I have encountered DX returning an error code
I have this error today

I started a new project and tried to see if the error also appeared here. What's interesting is that I can now also select the Android version for the new project. I don't see this option in my old project. I can upload the test project, no errors are displayed

January 19, 2024 new release had been officialized. Could that cause the issue ??

You now have Android screen selection in the designer as the default theme in AppInventor is now the device's default theme. Previously, the default theme was the Classic theme. Change the theme to classic and see if the compilation problem persists.
Have you added all the extensions that you had in the old project to the new project?

I removed all extensions, no improvement.
What do you mean by theme? Choosing the screen size? I have a choice of phone size, tablet size and screen size. Nothing happens with all settings. the error is still displayed.

found it, but no change, error still occurs.
Thank you

I have now reduced the content of the app significantly to see whether the app size plays a role. but I'm not having success with that either. I suspect that it is due to the release NB195d. Only when I start a completely new project does everything work. but I can't write an existing app into a new project

I can't send my aia here because it's too large

  1. OK, you are working on the code server, I do not believe this has been updated to nb195d

  2. Try shortening your aia project name. Export the project to your computer, rename it (e.g. myProject.aia), then import the renamed aia project.

I'm working on ai2 server but can't import aia so I have to do that

On ai2 server i have the error