Error 908 The permission

Hi ! I have searched an read all the threads about this very irritaiting issue...

I seems to fall on the first step... How do You set DefaultFileScope to Legacy.
Is it in the program or is it in the phone..

Or you have also blocks.

1 Like

Where did you get this error ("Error 908 The permission")? Show you relevant blocks.

You set it in the properties of the project, which is valid for all components except of the file component

It would really help if you provided a screenshot of your relevant blocks, so we can see what you are trying to do, and where the problem may be.

To get an image of your blocks, right click in the Blocks Editor and select "Download Blocks as Image". You might want to use an image editor to crop etc. if required. Then post it here in the community.


Trying to push the limits! Snippets, Tutorials and Extensions from Pura Vida Apps by icon24 Taifun.

Hi everyone !

Well it's hard to tell were the fault is... If I run the program with AI companion it works fine!

If I downloaded the app and run it throw the telefone then I got the problem. The app has worked fine for at least 4years and still does on old installations.

New installation = problem...

But it is a program that save, move and delete files

And again:

Well if I push button btnloggaInut in the app the
error occur...

That makes no sense at all. Why would clicking that button trigger a storage permission error?

Show your blocks from Screen3 (when click on the button, you open Screen3).

1 Like

I cant exactly se what generates the error. It workes fine when I run the code in the computer...

Screen 3


Post a screenshot of the permission error (Error 908...).

Well that was an answer on Your own question :wink:

"Why would clicking that button trigger a storage permission error?"

Are you testing this on a newer device?
Remember, that permission does only exist for older devices


Now we talking... not necessarily a new device, but new installation. With my phone a S21 has the app previously worked but now it does not..

How do You get permission for a new device ?

Tomorow it's Swedens nationalday and therefore most of the companies is closed so I will be back on Monday.

Sincerly Shas

Sorry, I meant a device with is running a newer Android version
Just remove the AskForPermission method and try again


Make sense, My device i running version 14 (The latest)


I have remove the AskForPermission and now the error is gone, thats nice :wink: but there is one small issue the app does not work

Doesn't version 14 needs permission to read write an delete ?