Error 1103 - Why do I get it now and I did not get it before?

I was able to operate a robot from my Android phone successfully. Now, when I go to MIT APP INVENTOR, repeat the same steps, and I try to scan the QR code I get Error 1103. I tried rebooting my computer, reloading and repeated the steps using the 6 character code (instead of the QR code). I changed nothing in my procedure, why did it work before and now it does not work?

Please provide a more detailed explanation of what you are trying to achieve,
what you have done so far, what works, what doesn’t work…

Please show your relevant blocks,
if relevant, your data or lists,
screenshots of the Designer screen or app in action,
so we can see what you are trying to do…

Right Click in Blocks Editor and select “Download Blocks as Image”
for the best image of your blocks.

On my laptop I go to MIT APP Inventor, then I click CREATE APPS. A graphic appears

Then I click CONNECT AI companion.
A QR code appears

I now run the MIT AI2 app on my Android phone. I continue without WIFI.

I then click on SCAN QR CODE on my phone. Here, the QR code would be recognized and the graphic would appear on my phone. But now, instead, I get Error 1103.

??? you need wifi to run the Companion without wires!

It worked without WIFI before, then it did not.
I just repeated the exercise with a USB cable between the laptop and phone. When I tried to scan the QR code I got Error 1103.

You most likely had WiFi connected without knowing - you can’t scan a QR code from the IDE without WiFi.

When using USB, it does not work with Scan/QR code - instead, you use the AI Starter program on your PC. However, that sometimes does not work, in which case you can instead compile an APK and transfer that to your phone either via WiFi or USB.

Ensure your phone is in Developer/Debug mode:

The same problem is happening to me too. Have this problem been solved? Is it necessary to reinstall the QR MIT reader?

Hello Fix_Falcon

So far as we can tell, it’s not an App Inventor problem. Certainly, two reports out of hundreds of thousands of Users suggests the issue is a local fault of some kind. Make sure the App Inventor IDE is the king of your browser, no youtube or spotify etc eating up broadband (no one else in the building using WiFi for movie streaming etc).