Error 1101 unable to get a response

Hi All,
Happy New Year.
I have some code which uses variable to create a MYSQL command to insert some data into a database it used to work but now doesn't, I get the error 1101 message.
The only change to the entre project is thet my ISP "migrated" my server to another platform.
I have reduced the code so the variables are fixed, but I still get the same message. If I send the complete url, (including the fixed values instead of variables) to the browser it works, this tell me the php code is working.
If I send the same line via the app I get the error, this looks like something happening with app inventor to cause the issue.
Here is a simplified block

what's the real url?
Better to make a demo app which can reproduce this problem, then upload aia here.

Ok, here is the basic demo of the app.
pressing the button gives the error, but placing the URL in the browser is OK.
is there any handshaking going on between the app and the server that I'm not aware of?
Template4.aia (5.1 KB)

I've just tested the same code on IOS and it works

Was testing and didn't work at first, but now just started working!

This means the code is relatively OK, (especially as it worked on IOS and from a browser), so there must be something why the app on android doesn't work

It worked for me on android 13

Even more interesting, I am using an Amazon Fire and it doesn't work.
I will try to load the emulator fro the MAC and see whether it works or not

probably won't work in an emulator....

Yes, you are correct, the app doesn't work in the simulator, but does work in the browser on the simulator.
If. you've managed to get it to run on a phone, then maybe something speciific to Amazon Fire , that is stopping it to work

Does your real app use TextToSpeech? TTS is not Amazon Fire friendly.

This particular app doesn't use TTS

I think it may be related to the migration of my server done by the ISP
If I replace the URL with something that doen't contain php I do not get the error.
Does anyone one here have something I dould use as a test to confirm my thoughts, meanwhile my ISP are looking into it.
They migrated my server, changed the servername and possibly the version of PHP, yet they do not know ehat the previous version was

Ok, I;ve managed to build another web server, tested the demo app on it, and it worked, so I've raised the problem with the hosting/ISP company

Morning guys,
I have had many problesm with the hosting company, which have all been fixed, now the problem is just related to the app and the url.
When the app worked I used the Web component, as far as I know nothing has changed yet the app just wont work
Is there a working example of how to use the Web component, with the Web1.URL and Web.get
My latest test is to have a simple php file on the website to display the time, so nothing complicated, yet I still get the error.

This may help:

It might be, your web host blocked access to your php scripts from outside...
I had the same issue with


latest update
Hi Timai2,
I've tried this
I get the 1103 error when the https:// is used, otherwise I get
Error 302
302 Found
The document has moved here.
I am totally lost as to what is happening,

Do you have an updated aia project to test ?

Thank you for looking at this, it works from the browser
Template4A.aia (3.6 KB)