Error 1101- Unable to get a response with the specified URL

I have made an app using MIT App Inventor where the app collects data and then sends it to a google sheet through a google form using the respective URLs. Whenever the data is being collected, I get the Error 1101: Unable to get a response with the specified URL. I have checked that my wifi connection is stable. Any suggestions?


1 Like

Need more details

1 Like

Hi! Thanks for your response!
Can you be more specific about the details you need?

Relevant Blocks showing these "respective urls" for a start, then...

Need to see this url in its entirety


Also I like to put this at the end of the url: (after your Label18.Text)

Entire first URL:

Should work....

I received this error? Does this mean something? I have not received it before

It looks like the error 1101 itself is gone, thank you so much for your help on that! However, I am now encountering a new problem, while the error is not showing up, the data collected by the app is not being received by the google form or the spreadsheet. I have tried to submit responses to the form outside of the app, and these responses are received. Any suggestions?

1 Like

Try just sending some dummy data to the form "inside" the app (copy the blocks and replace your variable data with text). - Just to post to the form, nothing else.

This will tell you if your "built" url is working or not. Then you can move on to discovering what else is causing an error in your block coding.

The error 1101 has begun appearing again...

If I follow your url in my browser I get:

see the extra /e/

  • Interesting, when following the URL, I do not get the extra /e/. I am inexperienced in this, but the rest of the URL looks different as well. Which URL did you follow, the one I had sent earlier or the one in the screenshot, or a separate one?
  • I tried sending some dummy data from "inside" the app earlier and, while no error appeared, the form/spreadsheet did not receive the response.
  • Whenever the error 1101 appears, the app does not send the collected data to the google form/spreadsheet. I have a theory that the error message sometimes appears delayed or does not appear at all, but internally the error is still occurring. Is this possible?
  1. The one you posted
  2. Strange
  3. Possible

If testing in companion, right click on your join block that builds the url and paste the output here (hopefully with all the sensor data included)

Is this what you mean?

ooh, just had a thought, some or all of your data antries may need uriEncoding.

Add this block to each of your entries:

component_method (1)

Sort of, but try the above first with the uriEncode block

I didn't get the error message (or maybe it's delayed or something), but the data still didn't send to the google form/spreadsheet