Emulator showing errors

In MIT App Inventor I got this message: Error from Companion: Attempt to invoke virtual method 'java.lang.String java.lang.Throwable.toString()' on a null object reference

I would copy the log but I can't figur

e out how to do it in Windows so I recorded a video instead.

Why not:

I already searched, and it seems the problem is that I’m using an outdated companion, (2.65 not 2.66) but I don’t know how to update it. None of the topics explain how to update it.

Welcome David.

See the section on Troubleshooting in Installing and Running the Emulator to get instructions about one way to update Companion to the emulator.

I tried using this method, but for some reason nothing was happening on my emulator screen.

Try loading a simple project; what happens? Does the Companion upgrade?

If it upgrades and still doesn't run I expect you have issues with your game coding.

I see you are using the aistarter technique (Connect->emulator), the most difficult one to sync.

It's much easier if you can get an emulator up and running on its own, with a Companion downloaded and installed onto it under your own control.

It still doesn't update and displays three blank buttons, even when I made a blank project.

How would I be able to do that?

See the Other Emulators section of Emulator showing errors - #4 by ABG

Alternatively, export your .aia here for one of us to examine.