EMULATOR not working windows 10

The emulator starts but wont run the app that I am making under guidance from the Shaw Academy. The online tutor runs the emulator fine and my phone runs the app when connected by USB!

What app? This is not the Shaw Academy help Forum. We would like to help but we have no clue what your are attempting to do . Either provide a better description and post your Blocks or contact Shaw Academy.

@JJCNsnr Are you able to start the emulator with a blank app? If not, then you may need to hard reset the emulator:

  1. In App Inventor, select Connect > Hard Reset
  2. Confirm the reset in the dialog (this will reset your emulator image to its initially installed state)
  3. In App Inventor, select Connect > Emulator, which will start the emulator
  4. Follow the prompts to start the upgrade when you are prompted about the companion being out of date
  5. In the emulator, follow the prompts to install the upgrade helper, which will download and install the latest companion app
  6. In App Inventor, select Connect > Emulator one last time to connect to your upgraded emulator

Thanks very much for your positive suggestions, which I have followed. The emulator will not update. I have many snips but maybe the most relevant one is a warning about "emulator: warning: opening audio output failed "
Might this have stopped it ?

To answer your initial question… yes I can start the emulator but it won’t run the app, even a very simple one with these blocks


I only mention Shaw to indicate it’s not some crazy app, and to introduce the fact that I have seen the app running in an emulator on some other PC. I don’t think the blocks are in issue. I used bigger, different images than the tutor, might the images’ size be a problem?

No, this isn't a problem, especially regarding updating.

Can you explain a bit more about where the update process stops? A successful update usually goes like this:

  1. In App Inventor, select Connect > Emulator
  2. Emulator starts and App Inventor connects
  3. App Inventor detects the out of date companion and asks you to upgrade
  4. App Inventor transfers an app called the CompanionUpgradeHelper, which the emulator will prompt you to install
  5. Follow the installation prompts in the emulator to install the CompanionUpgradeHelper
  6. In App Inventor, select Connect > Emulator again, which will kick off the upgrade process
  7. In the emulator, you will be prompted to confirm installation of the new companion
  8. After the installation finishes, App Inventor will find the new companion and connect

Usually, if there is a school or corporate firewall between you and App Inventor, there might be errors around parsing packages, etc. at steps 4 and 7. If you hit an error during the upgrade process, please include it as a screenshot.


Thanks again, Evan. I didn’t recall actually seeing the CompanionupgradeHelper. But these photos show it doesn’t get installed. You can just see the H. I thought Id got as far as upgrading the companion, but no such luck.

! 20200416_113922|375x500

This is a private house, with no firewall issues as far as I know.
I have uninstalled and reinstalled the software and the AI2 starter

Grateful as ever for your assistance

on researching I see with interest that Evan and Steve were both involved in a similar discussion in January 2018 !

Some things to consider that might help:

  • What browser are you using ? Do NOT use Edge …use Chrome or Firefox
  • did you install aiStarter to the default directory
    The file dates you see are old because this is an old graphic. You should see 2020 dates.

I installed the emulator using the guidance here on a new win10 desktop using the guidance here recently Instructions. The install worked as described. I suggest re-installing. Go to the App Inventor directory (see graphic above); click uninstall. Now after uninstall, turn your PC OFF. Reboot. install again but when you reinstall aiStarter.exe make sure you install aiStarter as Admin.Administrator
(right click instead of left clicking).


Thanks for that Steve. I was using Edge. Tried in Chrome same result.

BUT searching for the installation directory for .appinventor and it’s wrong!! Don’t know how that happened but it’s under the user directory not in programfiles(x86). Feeling very confident you’ve fixed it but don’t have time ti reinstall now. THANKS THANKS

Disappointment. I was misreading it. But the starter install default directory is in AI2 starter, not appinventor as sown in your picture. Going to have a run through the instructions you linked.

When you install the software, it MUST be installed to this directory . I just copied it from my Dell Win10 so there can be no confusion.

otherwise the emulator cannot find critical files. This directory is where the emulator looks for required information. When following the install directions, the AppInventor folder in Program Files (x86) is the default directory.

Uninstalling one more time. I have been using an AI2 starter downloaded from somewhere else. Happened the first time I tried to run the emulator. One time in the last hour I got a parsing error, but mostly the companion upgrade has just been “not installed”.

Oh Joy!
It worked. Had to do two updates on the companion, after the update helper worked for the first time. Then it took forever to load. cancelled rebooted and tried again, and the emulator is now running rolling dice app. A small start but seems like a small miracle to me ! Thanks so much Steve, and I apologise for my mistakes. You have done me a great favour.

1 Like

stop aiStarter.
download file https://drive.google.com/open?id=14JGNqx6FarAbjydfjie5_3fhdmczWGBm
Replace the same file in C: \ Users \ YOUR USER \ .appinventor \ emulator directory
Appinventor-emulator-data and sdcard.img

start aiStarter

Yong_Tang Thanks for your advice, but the problem is fixed. Can you provide some explanation of your suggestion?

I haven’t looked at @Yong_Tang’s file, but the Appinventor-emulator-data file is the disk image for the emulator. You can update the companion on another machine and then share this file with others. However, there is a risk factor by accepting the binary from someone else that it could have been modified in some malicious way (I’m not claiming that this has been done, just that it’s possible).

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.