Emulator issues

32 new laptops with ai starter give me this error. What can be done?

Hello Francesco

We need to know the setup of the Laptops:

  1. What is the OS
  2. Which Browser is being used.

… and the circumstances:
3) Were you running App Inventor successfully on these laptops before, or is it an all-new setup?
4) What happens if you follow the link on the pop-up error message?
5) Has anything been changed on the School Network? Have, for example, any ports been blocked that were not blocked before?

Chris, these are all new setups. They are Windows 10 using updated chrome. I never tried following any link though. I can’t find a pattern in when they working when they don’t. They mostly don’t work with emulator but I am not sure in the few times it does come up what makes it work. I am heading in now and will test again.

Where are you installing aiStarter Francesco and are you installing as Administrator?

Do you accept the default installation directory on drive C when using the installer or did you change the location?

Here is where your files should be stored on a brand new Win10 computer:

App Inventor 2 ‘expects’ the emulator to be located at the default location. If you cannot ‘find’ it and get the error message, that might be the issue.

Yes I install as administrator to the default location. It is installed for all users my students use a non-administrative account where the shortcut is on the desktop

Does your school network block ports 8001 and 8004? One of those ports (I think 8004) must be available to run the emulator.

The following may help you get this running if you have not read these articles previously

Hi @Francesco_Portelos,

This FileNotFoundException happens when your firewall blocks outgoing connections from the emulator to the server. The emulator needs to reach out to code.appinventor.mit.edu (or ai2.appinventor.mit.edu) in order to retrieve the update, and if the firewall blocks the connection then the update cannot proceed. You’ll have to go into the Windows Firewall settings and make an exception for emulator.exe to make outgoing connections.

I followed your directions and made an exception for outgoing rule for the emulator. Still having issues. Do I have to enter ports?

so I imagine that you have to check with your IT department to ensure the network does not block them Francesco. If they are blocked, un-blocking may allow the emulator to work.

You shouldn’t have to enter ports if you make a blanket exception for the domain. We’re just running on the standard HTTP port (port 80). Another possibility as to why it is failing might be due to DNS not being propagated to the emulator. What happens if you try to access ai2.appinventor.mit.edu from within the emulator browser? Do you get a webpage served back or do you get an error?

I either get this error or the browser closes and shows this icon attached.


I took laptop home and it updated no problem and worked when I brought back to school. As a workaround I used a teacher’s mi-fi to connect to non school network and updated all machines. Should be good until next update.
Should I tell IT department to unblock ports for school as the windows firewall attempt did not work.