Downloading the app inventor setup software

when I click the button to download the setup software it does nothing and when i open it in a new tab the tab just closes it self immediately

1 Like

The AI2 Setup software downloads a basic emulator and a program to start it, for debugging

The AI2 Designer and Blocks Editor are at
MIT App Inventor

For further info, see



I'm having the same problem as @Colton_Maler. I'm trying to use the emulator, and I need to download the App Inventor Setup Software, because, "Using the emulator or the USB cable requires the use of a program named aiStarter... The aiStarter program [is] installed when you [install] the App Inventor Setup package."
However, when I click the download link, nothing happens other than the page reloading very quickly (bad link, or self-redirect?), and when opened in a new tab, the page instantly closed itself.

I'm not sure what this means, would you mind clarifying?

Edit: I tried typing in the link itself into a new tab (, and it worked! :partying_face: It downloaded a file called "MIT_App_Inventor_Tools_2.3.0_win_setup.exe" with the correct icon.
[I also founds another thread (below) that gives another solution:]
Http:// - the site doesn't work

(Also, I am on Windows.)

Well that's good news :sunglasses:

I just tested the link on the MIT Site: fine with FireFox and Chrome