Companion app failing to connect - only on one computer


I am teaching in a PC lab. We are using iPads for the companion app. For four weeks we have had no issues, but today I began not being able to connect to the companion app, only from my personal teacher computer. When I log in to one of the student computers (same machines) with my account (my computer login and my MIT app inventor account) I have no issues. None of my students have issues. I can connect to my android phone just fine, but not the iPad.

I have tried restarting the computer and iPads both and nothing has changed. It continually gets stuck on loading whatever the last asset is.

Thanks in advance for any help.

Is this the same for all projects, or just one specific project?

Have you tried creating a blank project with no assets and using the companion with that?

Are you using AI2 companion or iOS companion ?

It will not load any projects at all anymore, no matter how simple. It is now spreading and impacting several of my student computers. It seems to happen the more projects students have worked on; deleting projects from My Projects does not help, however.

We are using whatever the iOS app is. I can take any of my iPads and they won't work on my computer, but if I go to any other computer (that still works) on my same network, they will open apps from my account just fine.

Now that ~10 of the computers in my 26 seat lab are no longer working, this is becoming a big issue rather quickly. I can have a student log into their account on my computer and it still won't work, so it seems to be a computer specific issue.

Your issue may be related to this issue using ios with Companion Students having issues connecting to iPad ,

MIT just provided work around the issue advice here> Students having issues connecting to iPad . Maybe that advice will help you.

1 Like