Comma issue in listview

I have data for 5 columns, but due to commas in the 3rd column, the CSV file is creating a 6th index. If there is a comma in the 3rd column, then the 3rd and 4th columns need to be merged. If there is no comma in the 3rd column, it should remain as it is. Is there any solution for this? I have attached a photo of the ListView for reference.

"" "Banka" "₹ 1,000.50 ( 0)" "₹ 2028.50 ( 0.50)" ""

"" "Khagaria" "₹ 995.50 ( 0)" "₹ 2021.00 ( 0.50)" ""

If that's supposed to be CSV (Comma Separated Values) in those two lines of text, they fail syntax checks.

Quotes around items are fine, sufficient to guard internal commas against misinterpretations.

But I don't see commas between items.

How is that text being generated?

Are those tabs (hex 08 = \t) between items?

Where is that list come from. Can you replace the comma with semicolon or something?

Show the raw data

In this screenshot, the value in column C is with a comma, causing a problem. What can be done about it?

We cannot replace the comma with a semicolon or something else in Google Sheets, This sheet is auto-generated.

Please show the data in your response content that is returned by your query.

the responseContent is a json, not csv, you need to parse it to List by Web.JsonTextDecode.

We really need see your raw data of responseContent.

If the data is coming from a Google Sheet, we have more options.

Try like this:

(you can see I have a comma in the last_name field in row 2)


1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.