Can't delete image

I am using App Inventor 2 on the MIT website.
My app has several images uploaded, including one that I want to delete.
Normally, I would click the image under the “Media” section (in either Designer view, or Blocks view) and then click the delete link in the pop-up window.
However, because the image I need to delete is near the bottom of my list of images, as soon as I click on it the screen scrolls up and the pop-up with the delete link flashes on/off.
Therefore, I cannot delete the image.
Is there a FIX?
PS. browser is MS Edge on Win 10.


Hi Crispy_Frog. Get out of MS Edge immediately, it is not compatible with App Inventor. Use FireFox or Chrome.

It appears this is a bug with nb183a. I see a similar response using Firefox or Chrome. Also take Chris’ advice and do not use Edge @ChrisWard



Export project to aia file on your computer
Open aia file with your unzipper
Open the assets folder and delete the image file you want to remove
Close unzip program
Rename aia file
Load aia project file

[EDIT] or maybe not having seen @SteveJG 's other post attempting this. Possibly an edit to the scm or bky files too ?

Steps to remove one or more files from assets:

  • open aia with 7-Zip or winRAR
  • open the assets folder
  • remove one or more files
  • close 7-Zip or winRAR

No need to rename anything.
The same procedure as shown here:

Thanks for all the suggestions.
I found an easy way to get to the delete link:
I used the browsers ZOOM function to reduce the view to 50%, then I could see the image I wanted to delete without the screen scrolling.
However, now, when I click delete I get the following message:

This site says…
An internal error has occurred. Report a bug?

Yes, I had tried this before and got the same error, hence my suggestion with instructions on how to solve this temporarily.

There is a bug in release nb183a that makes it impossible to delete Assets from the Media at the present time. MIT will eventually fix the problem. It might take a while to get fixed because of the holiday. The problem has been reported to the developers.

Please use @Anke 's advice as a work around until the real problem is fixed. Her advice works!

1 Like

@Crispy_Frog MIT repaired this issue on 4/13/20 with nb183b . Can you now delete images?

@SteveJG, Yes, I was able to successfully delete my image. I still had to set my browser to 50% zoom to stop the screen from scrolling up, but I can live with that. works for you too, so the main issue is fixed. Thank you.

When a developers adds a lot of assets to Media that does become an issue. Developers can, if they wish use PKzip to open the aia assets folder and then add or delete your assets there. Then saving (closing) PKzip. A developer can add many assets using that technique and not have to add assets one at a time, if he/she is careful.

Yes, I have to set less than 25% and I need a magnifying glass :wink:
so this should be fixed too. @ewpatton

@Anke what browser/OS combo are you using? I don’t see this behavior at the moment. Can you share an AIA with a large number of assets like the one you demoed?

Firefox, Chrome (current versions), Win 7 Prof.

testRemoveAssets.aia (477.8 KB) > 60 files in assets

Btw, no issues with that on my MacMini, Safari.
… try later / tomorrow on my Win 10 PC.

Thanks for the info. I’ll see if I can reproduce this on Windows (no issues with Chrome on macOS).

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.