Cannot install app with "Build" using AdHoc profile on iPhone with QRCode

  1. Created and downloaded AdHoc Profile from Apple
  2. Uploaded Profile in "Media"
  3. Successfully Built the Project and Got QR Code display in app inventor

When i connect using "AI Companion" it works on my iphone

However, when I try to "build" and install on my registered device in Apple, using the app inventor companion on my iphone, I get error: "Invalid code: Code Must Be Six Characters"

Kindly advise.

This is a limitation of the iOS companion. We had tried adding similar functionality to the Android companion but Apple rejected the change. Instead, you can use the Camera app to scan the code and it should work.

1 Like

Thanks. That worked. FYI it shows "open in iTunes".

If I do not want to turn on "Developer Mode" in security for me to install the app, what is the best approach?

Unfortunately, for iOS 17 and up I think you must turn on Developer mode to install apps ad hoc. This is a security change from Apple's end. As for "open in iTunes", the Apple specs require the use of a special itms:// URL for performing the installation, which the Camera app interprets as installing via iTunes even though the app package is provided from our own servers.

1 Like

ok. I tried building the app for "App Store" using the appropriate cert, however I get an error in the build log "[2024-05-13 14:17:43 EDT] ERROR: The username is not a member of the provider MITASC. Contact your team admin for assistance. (1296)"
I tried not putting an random ASC value and it complained that it was missing. What is "ASC Short name" supposed to be? How can I find it? I am building on a Macbook Air M2


I want to publish to the App Store, hence not use the AdHoc option unfortunately. It does not matter anyway as its not even building the app in MITappInventor.

I added the ASC but now I am geeting this error on build:

DBG-X: parameter DSTokenCookieName = myacinfo [2024-05-13 17:01:17 EDT]

ERROR: Could not find an application record with bundleId: com.mydemoapps.mitappinventor.HelloWorld. [2024-05-13 17:01:17 EDT]

DBG-X: Returning 1

Thanks Anke.
I am able to install the AdHoc app in developer mode now. But still figuring out why it fails when I try to build it for the App Store.
I have com.mydemoapps.mitappinventor.* as my bundle identifier. Could it be the wildcard that is causing it?


Hmm. The buildserver should handle replacing the * in the wildcard with the project name. I guess I need to double check that code.