AppInventor Support Android9

"Target Android SDK: 29 (Android 10.0)" ist not the goal!

It's a shame that MIT AppInventor 2 only generates apps in SDK29. So all those who have less than Android10 are excluded ...

we must have had a communication problem, I must have expressed myself incorrectly ...

But I can still run the App made using MIT AI2, even though my cellphone is SDK Version 28

Hello Michael,
It seems that you misunderstood the difference between the min. SDK version and the target SDK version,
Here you can learn more about them:


There was a topic about this too in kodular community:

3 Likes

OK! Then it's probably due to my phone.

Thank you very much for your patience.

Greetings from Germany

1 Like

You're welcome @Michael_Bernhardt :wink: :+1:
and don't forget to close this topic if your problem is resolved. thank you

What's due to your phone?
Where is the problem?

I sometimes work on my project. Most recently a year ago. If I let MIT AppInventor create the same project, the program crashes. I do not know how to continue. Maybe I have a little time between the holidays to check it out ...

Extensions can be a problem if you have them in your application.

Post the blocks.
See here (→ point 3):

in my project there are three extensions. I have to try if it works without it. thanks for the tip!

Maybe one of them has not yet been updated to the AndroidX libs.

1 Like

Hallo Anke!
that could definitely be my problem. i will test it! many thanks!

Hello everybody!
It was really an extension that caused my project to crash ...
The extension was sidebarV2 by Andres Daniel. The ones that are there now seem to work!

Thanks to everyone who helped me with their time! Thank you very much !!!

From where did you get this extension (version 2)? → link?

Same question as above.

See also here:

The companion doesn't work, but after building the APK it will be OK. On the other hand, you have Android9. The sidebar should work with this version.

it does not work
but worked in the past
working

yes, I have now used the extension Sidebar Navigation Extension by Andres Daniel
works great with my oneplus 3t

Yes, this (old) version doesn't work with Companion & AKP on Android 10 & 11.

So there are 3 versions of this extension (free version):

  • sidebarV2 (Appybuilder)
  • sidebar (Thunkable) with development checkbox
  • sidebar (Thunkable) without development checkbox

Neither of these work on Android 10 & 11 with Companion.
The Thunkable versions only work with the APK.

@Andres_Cotes @Taifun

thank you, I added a note in the extensions directory
Taifun

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.