App Inventor Http Get Request Not Working

You have a private message....

Well I setup a yelp account and got an api key.
Ran your url with these blocks

and here is the return, data as requested....


1 Like

Tested with your api key and it also returns data

Huh. what could be different on my end. Maybe if I set a variable for token?

Try with just the blocks that I have used...

(successful sample added to FAQ)

I don't understand I've done everything the same and it still doesn't work.

If its not the code that's the problem or the key, could it be the phone I'm using or the version? I updated the companion app to version 0.9 in test flight. I'm using an iphone SE to test it.


I know nothing of ios or test flight.

Suggest you try an android phone ?

I'm looking into the possibility that its my network or something. I'm stuck with an apple phone unfortunately. I guess I'll post back here if I fix my problem if not I'll just drop it and do something else.

According to "does appinventor run ios" the web component should be working OK

Alright I think I figured it out. It works on android phones and not ios. I had a different friend test it out with his android phone and it worked fine, but when he tested it with his iphone it doesn't work. It was the exact same code and internet connection just a different testing device so I think that has to be it.

If you send me the AIA that works on Android, I can run some analysis on the iOS version and see what's going wrong.

aia sent via PM

Thanks @TIMAI2. I've identified the problem and have come up with a fix. It'll go out in the next iOS version.

When do updates come out usually if you don't mind me asking?

We've been aiming for once every 3-4 weeks.

Okay I guess I'll wait for that. Thank you @TIMAI2 @ewpatton and @ABG for the help.

Thanks Evan :slight_smile:

This should be fixed in iOS 0.9.10, which was pushed out via TestFlight last night.