aiStarter not recognized anymore

Hello

Two days ago it started that when I try to start the emulator, I get this error message:

image

And this is the error in the Developer Console of Chrome:

Very interesting indeed, perhaps this may help you: https://support.gpsgate.com/hc/en-us/articles/360008588579-Access-to-XMLHttpRequest-has-been-blocked-by-CORS-policy

1 Like

After doing some research it looks like it could be because of changes to Chrome 94.


It affects Edge too because it is Chromium based. The update prevents non-https public websites (the app inventor site) from accessing private networks (the aiStarter app).

1 Like

Also see here:

https://community.appinventor.mit.edu/t/unable-to-retrieve-the-version-of-a-aistarter/42098/13

I've tested the following workaround in Chrome which seems to resolve it

  1. Open Chrome
  2. In the address bar type chrome://flags/
  3. In the search box in that page type CORS
  4. Under Block insecure private network requests change from Default to Disabled
  5. Click Relaunch at the bottom right

My understanding is that this would not be an issue if http://ai2.appinventor.mit.edu/ was an HTTPS site so hopefully that is fixed at some point

3 Likes

I will test your solution as I had a similar problem. If it works then I think it should be added to the emulator documentation. Due to the advancement of browsers and security, old documentation is not always up to date.

(added to FAQ)

Yep - that's it. Worked. Thank you so much. This is really a fantastic community!!

I'm using Edge here, and I can report - I can connect to the Emulator just fine.

Like Chrome it only seems to affect Edge version 94 and up so if its working with default settings then you're likely still on 93 or below. The steps I gave work the same way for Edge though if it ever gets to a point where it stops working for you

1 Like

I'm on Version 94, according to my browser.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.