aiStarter Connect Emulator not working Windows 11

aiStarter was working fine under Windows 10 Pro. It would open an emulator screen to test an app written here.

Had to upgrade to Windows 11 Pro, and now it doesn't work. The Emulator screen has a little screen open that shows, "Not Responding" instead of the emulator.

aiStarter shows some info, and then loops continuously showing: - - <time> "GET /echeck/ HTTP/1.1" 200 39

until I close it.

This is what it shows:

I have tried running Windows 8 Compatibility and Run as Administrator, and using those options, the emulator screen doesn't even open.
Any ideas ?

Is your Windows 11 device running on an Intel process or an AMD processor?

Intel i7-11800

Ok. So my current hunch is that the version of the Android emulator we bundle is not compatible with the more recent changes Microsoft has made to the Windows Hypervisor, given the error message contents. We bundled a slightly older version that what's currently available via Android Studio since the latest version doesn't support Windows 7.

If you have Android Studio installed, you might want to try copying the qemu folder from the Android Studio emulator over to the from-Android-SDK folder in the MIT App Inventor folder to see if that fixes the problem. I'll see about getting my hands on a Windows 11 machine for debugging this on our end.

Adding some info to this item (to hopefully shed some light): I'm running Windows 11 Home on a Intel i5. The Inventor Tools version is 30.265.0 The aiStarter does start correctly. But when it loads the app, the app restarts continuously until this Runtime Error appears:

BTW the previous comment was running in "Legacy Mode". I ran it without the option checked with the same behavior. Here is a 8 second video of the emulator restarting the App (the App is the Calculator from the tutorials).

Does the emulator load other Projects than your Calculator app correctly or does this happen with all your Projects? Try another Project and let us know what happens. :slight_smile:

Does your Project load properly using a real Android device and live development with Companion.

The question is your issue an emulator issue or an issue with your Calculator Blocks.

Try to determine the Companion version on your emulator.
It should be 2.66 or 2.66u according to AI2->Help->Companion Information.

There are alternative emulators you can try too.
My Windows 11 Home laptop required a manual script run to set up its Virtual Machine environment.

It happens with any project. All with the same behavior as in the 8 sec video: stuck in a seemingly, uncomplete init loop.

Yes. With all projects. I'm running flawless live development in an Android 11 tablet w/AI Companion

An emulator issue. I´m totally happy using the AI Companion in my Android tablet. I was trying to have the emulator as an alternative (...shhhh... to develop while at work ... :innocent:). when I found this posting and shared my experience in case the error message sheds light into emulator in Windows 11.

Yes! I saw several, with perhaps the GenyMotion the most promising. I also code in VS Code, so also MSoft's emulator might do.


Thanks. The behavior is consistent with an emulator Inventor Tools version 30.265.0 issue.
Running that emulator on PCs with AMD processors appears fraught with issues. Many people seem to have no or few issues using an Intel processor except on some laptops. What cpu does your Win11 have.

I would follow ABG's advice. This emulator seems still buggy. :cry:

I'm running Windows 11 Home on a Intel i5. The Inventor Tools version is 30.265.0

Do you have a copy of the project you can share (privately)? Generally, it should not ever be the case that there is a null Throwable (Throwable is the top level class for errors, so if there's a need to show one there should be a corresponding error--otherwise if there's no error things should have succeeded). If we have example projects that can replicate this issue we can fix it for everyone.

No problem. The one I used in the 8 sec video is the Calculator from the tutorials. Another example is one of my projects (a letterboard).
Calculator.aia (12.1 KB)
customKeyb3 (4).aia (53.8 KB)

BTW: as mentioned, I see this behavior in my Windows 11 Home + Intel i5 but also in the Windows 11 Enterprise + Intel i5 from work.

We are having the same issue on Window 11 Enterprise 22H2 with Intel i5 12500 running in a computer lab.

When installing 30.265.0 the haxm installer fails as it is not supported for windows 11. We get the same qemu.conf errors as the original poster.

The older 2.3.0 installer gives java script errors when launching the emulator on the same setup.

See aiStarter Connect Emulator not working Windows 11 - #9 by ABG for alternative emulators to try.