Abnormal behavior in App Inventor

Abnormal behavior App iventor
Hello everyone, thank you again for your work, please can you explain to me in some way because for days, every change I have made to the project has been difficult for the following reasons:
-I want to copy a text from one textbox to another, sometimes it executes the command sometimes not.

  • I have to enter a data in a text box, until a few hours ago it did it perfectly, I have not made any changes to the project in that section for days, but as soon as I start the project it behaves as I had already indicated a few days ago, operations that before he performed perfectly, now he does not perform them anymore, and then returns to perform them without my ever intervening.
    I am not going to list other anomalies, because for days I have been dedicating hours of programming replacements and so on without any result.
    After a while it works regularly, it starts giving these problems. I've been working on this project for months, something like this has never happened.

For several times I had to resume old projects, which worked regularly, then I made the changes and everything worked regularly, I close appinventor and restart it after a few hours, or after a few days and the project no longer works even some components do not perform the simple operations that they should perform, and then perform them normally after several eliminations of the same.

It will certainly be my fault, obviously for some time I have been making changes before saving the .aia file and these create this problem? But assuming that's really the case, do I keep making the same mistake I never made? In three years.
I did everything I could.
-reinstalled the operating system.
-Google Crome
and so on but all of a sudden everything goes back to working abnormally.
Even when he compiles the project after less than 10 seconds he displays the message: too many seconds have passed, the project cannot be compiled.
Sometimes it compiles the project, I click on the apk download and it gives me the same notice.
Also, sometimes it takes endless minutes to download the package, you have to give it up and close everything, yet my connection works perfectly.
As I wrote, all this has been happening for days.
When I worked from the first day on the project in appinventor2 over 12Gb, everything worked regularly for days and days but then as written the anomalies began.
I cannot post the threshing floor to you which would not be useful anyway because what I have listed are simple operations.

It is because of your browser, hardware specs and large amount of blocks and PC performance.

Don't say that.

Break down the details of your aia project:

  1. If you export the aia project to your computer, what size is it?
  2. Which app inventor server are you using?
  3. Which browser are you using?
  4. How many real screens in your project?
  5. How many assets, and what type of files, and what size are the files?
  6. How many blocks on each real screen of your project? (not that this should matter...)
  7. Provide an example aia project which demonstrates this abnormal behaviour (you say it happens on multiple projects...)

Be concise and to the point

  1. 12GB - (has always worked flawlessly)
  2. The server that accepts files over 10GB - (has always worked without problems)
  3. Crome- (has always worked without problems)
  4. one the main all the others about (5) are virtual- (always worked without problems)
  5. About ten images for the buttons do not exceed 1 MB. 4 .mp3 4.67KB each-280, approx .csv file (always worked without problems)
  6. do not exceed 6 10 blocks - (has always worked without problems)
  7. I don't remember if he did it on other projects too, I wrote about 1 project, I didn't check if the anomalous behavior also did it on other projects. I will take care to ferify it.

It is always the same PC and the blocks are always the same, there are 95

12 RAM ram
Nvidia geforce 950 gtx video card
Win 11

  1. Sorry, your aia project is 12 gigabytes in size ? really :exclamation:
  2. Which server ?
  3. You said it happened with other projects....

Are you doing anything "interesting" at screen initialise, like loading/reading ALL your csv files, or something similarly cpu/memory intensive?

If you are unable to reproduce the behaviour with an example project, then this would indicate that something is wrong in your blocks code, you should show your relevant blocks

How do you know it's 12 GB? :upside_down_face:
This is of course impossible as the maximum size of an aia is 30MB or 50MB for http://code.appinventor.mit.edu/.
Even with AI2Offline, no aia larger than 60-70MB can be used.

So export your aia and show us a screenshot showing the size.

1 Like

14MB sorry

I was focused on the 12 GB of Ram.

The server is: http://code.appinventor.mit.edu/
server for more than 12 MB. not 12 GB, sorry I was so embittered about what happened, that I wrote incorrect things.

I didn't say that it also happened on other projects, I said I don't remember it, but I think so, but in any case I don't remember the projects.

As soon as it happens again on other projects I will post the threshing floor

But trust me, it's been happening for days, and I'm not adding large blocks, just "copy a text to another texbox and 3 timers for choosing 3 operations with TextToSpeech.

I ask you: could it be that I have used too many components of the same type?
Or maybe I have reached the overall limit of the components to add.
How many components can be added of the same type or in total, is there a limit?

This sounds like a recipe for disaster :wink:

1 Like

14.3 MB -- APK
8.89 MB -- AIA

Something altered after exporting the APK?

I can speed up the Blocks Editor by doing up a Clean Up Blocks.

Do it on a copy of your project, because it is irreversible.

But of identical blocks with texts ranging from one texbox to another, the project is full.

Now I update you, I have not changed anything except replacing the two textboxes and miracle everything works, but strange case, now when I try to pass a name, from a ListPicker that automatically reports the name in a texbox of another virtual screen, operation carried out dozens and dozens of times, without any problem, it executes the action, but instead of displaying the screen with the name, it goes to the general screen.

The code is correct and it always executes and it should switch to the tab with the name but it doesn't anymore.

I repeat it will surely be my fault, but, it is difficult for me to find out what mistake I make, never happened so many times, but everything is possible, so I thank you and I will wait for some other miracle to fix everything. or I hope that a few more coffees will enlighten my mind and understand what is happening and where the mistake lies. Hello and thank you all for your patience and your help.

Yes, now everything works as I wrote but from another problem.

It wasn't for you but for ABG


Now there appear to be two of you with exactly the same problem ?

Can at least one of you please provide an example aia project that replicates this reported behaviour ?

No, it's always me who used another user for another request. not remembering the user I did not notice what happened.

I'm freaking out with all this chaos. what happens to the app.

So I apologize and understand how confused you must feel.

I don't know what happens I must have opened the card with that user. thinking it was my officer and just not remembering it I wrongly compiled answers that were addressed to you. and ABG

Anyway I ran the clean operation ..., now I will check if the apk works.

First answer:
I was saying that now the problems are both there, even what seemed solved.

Second answer:
I cannot post the blocks for contractual reasons.

third answer:
I drop the discussion because I'm making a lot of mistakes even writing.

We will talk to each other when I understand better what happens.