Yandex Translator didn't work

Any help about Yandex Translator? the picture of the component change and when we use it our app didn't work.

The Yandex Translator has been replaced with "Translator", it should work in exactly the same way.

Show your blocks of how you are using Translator component.

The component changes

as requested....

Replace the Yandex blocks with the new Translator blocks

Its the same.. :frowning:

Send Your AIA

You appear to be using ios...

Doesn't look like you changed the blocks. You may need to delete your current translator blocks, remove the component in the designer, then drag out the new Translator component ?



what AIA means?

I made a new one but its all the same. :frowning:

Unfortunately, the Translator component is not yet available on iOS. You can review this page for compatibility coverage between the Android and iOS versions:

1 Like

I think you tried on android
But you tried on ios
Translator dont work on ios
Try on android device
(AIA=App Inventor project file)

Ok, me and my students have tried everything but it didn't work on their end too. They are android users too and problem is still the same.. :frowning:

Android should be fine though. On Android, they should get an error message and number if something goes wrong. On iOS, you'll just get an error about an undefined irritant Translator.

Which version of the App Inventor companion do they have installed? The translator component was introduced in 2.63 and the currently published version is 2.65.

If you're doing this on a restricted network, you may need to make sure that your IT staff have allowed HTTPS access to, which is the server that provides the translation service.

1 Like

Ok. that would help. Thank you very much

This compatibility report was last updated on 2021!

Thank you so much. Btw it works on other students phone( Android). Hopefully there will be an update to IOS. Appreciated.. Thanks