"YAIL Compiler - DX Execution fail"

Hello yet again, inventors.

I've run into an error that says "YAIL Compiler - DX Execution fail".

I already tried looking for an answer in the forum but I can't find anywhere else. I went through Steve's monster list already (went through it three times) and it passed every checkmark. I can't figure it out. It says that it's not because of an error in my code.

I closed all my tabs, all my windows, AI is the only thing I have open.

Any help is appreciated. Thanks.

resend_copy (1).aia (626.4 KB)

EDIT: If someone can compile this and it is successful, could you upload it? Thanks.

When I tried to compile it said the build server is currently busy.


What abou trying on http://code.appinventor.mit.edu?

EDIT: Apparently the DX execution error still happens there.

I tried to export using this subdomain and still got the same error. Thank you, however.

Apparently after removing the ClickZ extension the app is compiling. Extensions might also cause the DX error. You might want to try an alternative, such as ComponentUtil.



OK, I see. Thank you very much. I appreciate you going through the app and finding my issue. :smiley:

No problem. I've replaced the extension, and now the app is compiling.

resend_copy_1.aia (645.3 KB)

1 Like

Wow. You really went above and beyond. Thank you so much. I really can't thank you enough.

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.