Y try to compile apk and stuck to 30%

hi someone helpme?. i try to compile and i didnt use extension, i reinstall the app inventor offline but the same result, and just try creating a new proyect but the project is empty, try to compile but get the same result to 30% stuck unable to compile. its my pc or other problem?

Have you tried on MIT server?
or you have to ask the maker of the offline version.

You can't compile an empty Project. Does the Project run OK on your Smartphone via the Companion, or does that also get stuck?

Note, there isn't an official offline version of MIT App Inventor and the files produced by 3rd party offline clones (and online clones) may not load correctly into App Inventor.

ok i understand but in other oportunities the app inventor offline work fine. i dont know why cant compile. i know that there isnt a official version. y try other version but the same problem exist. i read in the forum about a proyect inside a proyect...

i try later this and post when i try in the official server... and not a version offline.

If you would like to upload your Project (,aia), I can try to find the cause of the issue for you.

App Inventor
Export Project

Upload to your Forum Topic

here is the error
animacion_hablar.aia (198.6 KB)

I compiled successfully on code.appinventor.mit.edu.

You are using AppInventor Offline, not the official MIT AppInventor. AppInventor Offline is maintained by a third-party developer, and the MIT has no guarantee that this will work. This is MIT AppInventor community, so please visit AI2Offline / Discussion to discuss instead.

Next time please edit your title to make it clear for users.

1 Like

No issues (with http://ai2.appinventor.mit.edu):

1 Like

so the problem is the offline version?

AI2Offline (no issues):


why get the error and cant compile with the offline version?

Which version?

4.6 ultimate ramiro version

the version is in the page sourceforge

my pc using windows7 and i reinstall but get the same result

You shouldnt use ultimate. It is not maintained anymore. Last update was 2018!

I complied it with ver 4.6.4