Win 11 wont start aistarter

used on win 10 but since i upgraded to win 11 cant get mit to install it asks me to run with admin rights but then i command window says aistarter waiting for some responce press ctrl c to quit and app dont work or doesnt even seem to be installed please help cheers

@Justin_Jones Do you have a screenshot of the last error? That potentially sounds like normal operation of aiStarter, which just facilitates connections from App Inventor to the emulator. In the App Inventor interface, use the Connect > Emulator option to start the emulator (which will do so via aiStarter).

Hi thanks for the reply so installed the app from mit and it completes leaving a cmd box on the screen however it seems if i close that box it wont launch using the emulator says aistarter not running so are you saying that the cmd line box needs to be open to test emulator ? if so then if i restart machine then the cmd box closes so how do i restart ai so that emulator can run as im a little confused it never used to be like that on windows 10. I am trying to use it to build a gui to control some leds on arduino but not having much luck and finding it difficult to test.

The command prompt is aiStarter. It doesn't have a graphical interface. It's really just a web server that App Inventor talks to as an interface to the emulator.

If that is the case, the emulator may not be able to help you as it is not able to emulator Bluetooth or Serial connections to external peripherals. To validate those features, you need a real device.

Hi thanks i understand now how it works not tryed the emulator but get it and see it in appz on pc i understand that it may not work with the project i am trying to create but i need to make an interface that has buttons and need an indication of when the button (switch) is on or off i think im on the right track now thanks for the explantion i am currently looking at different posts to gather further info that might help me to use the app. Thanks again